bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

KOI8-U support in Emacs


From: Serhii Hlodin
Subject: KOI8-U support in Emacs
Date: Wed, 22 Aug 2001 17:11:08 +0300

Dear Contributors!

I make patch for Emacs 20.7 (with mule and leim) for support KOI8-U
charset in Emacs with mule.

Please, include this patch to next version's Emacs.

This patch have three files:

     1) emacs-20.7.koi8-u.patch -- for Emacs
     2) leim-20.7.koi8-u.patch  -- for Leim package
     3) ispell.patch            -- for ispell.el

For appling this pathes:

    tar -xzvf emacs-20.7.tar.gz
    tar -xzvf leim-20.7.tar.gz
    cd emacs-20.7
    patch -p1 < emacs-20.7.koi8-u.patch
    patch -p1 < leim-20.7.koi8-u.patch
    cd lisp
    patch -p0 < ispell.patch

If needed, please, copy byte-compile-codes from directory

   byte-compile-code

to source tree.

Configure, compile and install Emacs. After running, in "Mule" menu You
must be have KOI8-U support in "Describe/Set Language Environment"
("Cyrillic" submenu).

Authors:

        Oleg Tihonov <address@hidden> -- original patches
                              for Emacs-20.4

        Serhii Hlodin <address@hidden>   -- patches for
                              Emacs 20.7 (based on patches by Oleg
                              Tihonov)

-- 
With best regards,
                Serhii Hlodin




reply via email to

[Prev in Thread] Current Thread [Next in Thread]