bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

invoking process under emacs


From: Manish Khettry
Subject: invoking process under emacs
Date: Fri, 14 Sep 2001 14:31:45 -0700

When I try to run compile or grep under nt emacs I get the following error:
Spawing child process: invalid argument.

With the flag debug-on-error set to true, this is the backtrace.

Signaling: (file-error "Spawning child process" "invalid argument")
  start-process("grep" #<buffer *grep*> "/bin/bash" "-c" "grep -n -e foo
x.java NUL")
  start-process-shell-command("grep" #<buffer *grep*> "grep -n -e foo x.java
NUL")
  compile-internal("grep -n -e foo x.java NUL" "No more grep hits" "grep"
nil (("^\\(\\([a-zA-Z]:\\)?[^:(  \n]+\\)[:(  ]+\\([0-9]+\\)[:)  ]" 1 3)))
  grep("grep -n -e foo x.java")
  call-interactively(grep)
  execute-extended-command(nil)
  call-interactively(execute-extended-command)

I'm using windows 2K.

I do have /bin/bash-- atleast in my bash shell ls -l /bin/bash returns this:

address@hidden c:/glue/electric/src/examples/invoke
$ ls -l /bin/bash
-rwxr-xr-x    1 Administ None       474112 Sep  7 10:44 /bin/bash


Thanks,
Manish

Output from bugemacs is below
=====================


In GNU Emacs 20.7.1 (i386-*-nt5.0.2195)
 of Tue Jun 13 2000 on buffy
configured using `configure NT'

Please describe exactly what actions triggered the bug
and the precise symptoms of the bug:





Recent messages:
Spawning child process: invalid argument
Fontifying *compilation*...
Fontifying *compilation*... (regexps...........................)
Spawning child process: invalid argument [2 times]
Fontifying *grep*...
Fontifying *grep*... (regexps....)
Spawning child process: invalid argument
GNU Emacs 20.7.1 (i386-*-nt5.0.2195) of Tue Jun 13 2000 on buffy
Loading emacsbug...
Loading emacsbug...done




reply via email to

[Prev in Thread] Current Thread [Next in Thread]