[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: can't dump emacs-21.1 on redhat 7.1 nfs-mounted file system

From: pol
Subject: Re: can't dump emacs-21.1 on redhat 7.1 nfs-mounted file system
Date: 29 Oct 2001 08:02:29 -0800

> So, the size and modes are right, but the file contains only zeroes,
> and only 16kB of the apparent 6.6MB are allocated.
> The file system I'm building on is nfs mounted from a freebsd file
> server, so it's possible there's some bizarre nfs interaction going
> on.  Also, I noticed that undump opening files with linux's large file
> support enabled, so I though I'd try varying that as well.  I tried
> the following three build cases:
>         (a) nfs build directory, no configure options; 
>         (b) nfs build directory, --disable-largefile; and
>         (c) local build directory, no configure options.
> Both (a) and (b) exhibit the same problem.  (c) creates a proper
> dumped emacs.
> I've investigated somewhat, and it appears that the undump process
> uses the mmap system call on linux.  So, it appears there's either a
> generic linux problem with mmap on nfs-mounted file systems, or some
> sort of incompatibility between the linux nfs client and the freebsd
> nfs server.
> I did a bit of web searching, and in at least some corners of the
> world, mixing mmap and nfs is not considered highly likely to work in
> general.
> Dale Hagglund.

Hello, very thanks i have the same problem on a RedHat 7.2 and i had
not thought of nfs-mounted directory. I thought that that came from
the compiler... but not.

I tried to compile emacs on local directory and that created a proper
emacs binarie.

For information my nfs server is on solaris ..

pol tuiu

reply via email to

[Prev in Thread] Current Thread [Next in Thread]