[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Crashes when pressing ^G in minibuffer

From: Alf-Ivar Holm
Subject: Re: Crashes when pressing ^G in minibuffer
Date: 30 Oct 2001 09:52:01 +0100
User-agent: Gnus/5.090003 (Oort Gnus v0.03) Emacs/21.1

> Alf-Ivar Holm <address@hidden> writes:
> |> I've not managed to reproduce this error in an empty emacs (-q), but
> |> I've got this crash twice while running gnus (and lots of other setup
> |> stuff loaded from a lot of different files) and both times while I was
> |> editing the prompt to "M-x man".  The initial message and backtrace
> |> from gdb (Note: emacs21 was started with "run -nw" in gdb):
> |> 
> |> Program received signal SIGINT, Interrupt.
> |> 0xfef9629c in _poll () from /usr/lib/libc.so.1

"Eli Zaretskii" <address@hidden> writes:

> I'm confused: this isn't a crash, this is SIGINT.  SIGINT is the
> signal produced by C-g in Emacs.  And since you pressed C-g, it's
> quite expected to get a SIGINT.

After I sent the message I got the feeling that I had done something
wrong when debugging.  I'm sorry.  All I can say is that I had an
initial crash (without running under gdb); I lost the signal
information from the crash and there was no core file so I tried to
run emacs under gdb instead to catch the error the next time, a
strategy which fooled me.

Now I'm a bit puzzled myself: How do I run emacs with -nw under gdb
and disable/remap ^G?  I use ^G far too much to be able to work
happily without it.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]