[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Problem compiling Emacs 21.1 - coff.h not found in src/unexec.c on ISC

From: Andrew Wiseman
Subject: Problem compiling Emacs 21.1 - coff.h not found in src/unexec.c on ISC 4.1a
Date: Tue, 6 Nov 2001 14:31:36 -0000

When trying to compile the new version of GNU Emacs

GNU Emacs version 21.1
on my Pentium PC 
running SunSoft Interactive Unix 4.1a (i.e. 4.1 with the maintenance

make -k causes all of the source code to compile, except for unexec.c,
giving the error:

unexec.c:175: coff.h: No such file or directory

Looking at src/unexec.c we see:

174: #ifdef COFF
175: #include <coff.h>

and indeed, my machine has no coff.h in either /usr/include or
/usr/sys/include (or anywhere else on the disk).

I had run the configure program without any arguments, and it picked up
i386-pc-isc4.1a automatically.

It decided to use gcc to compile, which is version 2.7.0.

The source includes m/intel386.h and s/isc4-1.h (which includes
s/isc3-0.h, which includes s/isc2-2.h, which includes s/usg5-3.h, which
#define's COFF.)

I tried adding "#undef COFF" to the top of s/isc4-1.h then doing a "make
clean", followed by another "make -k" to see if I could get around the
problem. But this time I got a lot of error messages about trying to use
undefined structs.

Then I tried replacing "#undef COFF" with "#define CANNOT_DUMP". This
got rid of the error messages, but the final binary refused to compile,

then we get
undefined                       first referenced
 symbol                             in file
wait3                               process.o

So now I'm at a loss.

I have previously compiled old Emacs versions (19.28, 19.29 and most
recently 20.6), without too much difficulty.

Any help gratefully received!

Best regards,
Andrew Wiseman

reply via email to

[Prev in Thread] Current Thread [Next in Thread]