bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Emacs-21.1/Motif - Control+mouse not registering


From: maierh
Subject: Re: Emacs-21.1/Motif - Control+mouse not registering
Date: 05 Dec 2001 08:30:55 +0000
User-agent: Gnus/5.09 (Gnus v5.9.0) Emacs/21.1

address@hidden (Richard Stallman) writes:

> What happens if you use LessTif instead of Motif?

It seems to work fine with LessTif. After compiling on a Solaris 8
environment I tried it too on a GNU/Linux system. And on the GNU/Linux
system within a Open Motif environment I could observe the same
behavior. In the case of the c-mouse-1 case you have to release the
control key so that selection of the buffer in the popup buffer has an
effect.  Personally I don't think that this is a critical bug. I am
working on such a box very often and to the beginning I wondered what
is wrong. But I adapted myself very fast to the inconvenience of the
system. And now I don't think it's annoying. I am always releasing the
control key and then all works fine. Anyway the Xaw and the LessTif
behavior seems to me a little bit more accelerated and reasonable.

In the case of c-mouse-3 (the edit menu) all works fine for me on all
three test environments. I don't have to release the control key. 
Copying and cutting works fine.

Harald

Here the three tested versions:

GNU Emacs 21.1.2 (i586-pc-linux-gnu, Motif Version 2.1.30)
=> (false)
GNU Emacs 21.1.1 (sparc-sun-solaris2.8, Motif Version 2.1.0)
=> (false)
GNU Emacs 21.1.3 (i586-pc-linux-gnu, GNU/LessTif Version 2.1 Release 0.93.14)
=> (true)

Kevin Broadey wrote:

> Running emacs -q -no-site-file under X-Windows, if I do
> control-mouse-1 to pop up the buffer menu (runs the command
> mouse-buffer-menu) and select a buffer from the list, then Emacs DOES
> NOT switch to the buffer when the mouse button is released.  However,
> if I do control-mouse-1 and release CONTROL before mouse-1 then the
> buffer switch occurs as expected.
> 
> Similarly, if I use mouse-1 to select some text in a fundamental-mode
> buffer and then use control-mouse-3 to pop up the Edit menu, selecting
> Cut an releasing mouse-3 has no effect, but if I release CONTROL
> before mouse-3 then the command works as expected.
> 
> This problem does not occur if Emacs is built with the Lucid toolkit.
> 
> I an running Emacs on a Solaris workstation from a remote
> X-Workstation - a Windoze-2000 Pro PC running Hummingbird Exceed.
> 
> Just tried using the Sun workstation's local display, mouse and
> keyboard.  The same problem occurs.
> 
> My guess is that the modified mouse-up event is being ignored.
> 
> --
> Kevin Broadey



reply via email to

[Prev in Thread] Current Thread [Next in Thread]