bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: ps-print


From: Kenichi Handa
Subject: Re: ps-print
Date: Fri, 7 Dec 2001 20:56:03 +0900 (JST)

Martin Guertler <address@hidden> writes:
> when trying to ps-print-buffer the files ps-prin0.ps and ps-prin1.ps
> are not found because they are in etc instead of etc/ps-print where
> they are expected.

Have you tried it by starting Emacs with "-q" argument?
Aren't you using X-symbol package?

The attached is a mail relevant to this problem.

---
Ken'ichi HANDA
address@hidden

Date: Fri, 23 Nov 2001 14:38:36 -0200
From: Vinicius Jose Latorre <address@hidden>
To: address@hidden
CC: address@hidden, address@hidden
In-reply-to: <address@hidden> (message from Kenichi     Handa on Thu, 22 Nov 
2001 17:49:34 +0900 (JST))
Subject: Re: locate-data-directory


> So, if X-Symbol is loaded before ps-print,
> ps-postscript-code-directory is set to ".../etc/ps-print",
> thus we can't find necessary *.ps files on Emacs 21.

I'm thinking to change ps-postscript-code-directory definition to:


(defcustom ps-postscript-code-directory
  (cond
   ((eq ps-print-emacs-type 'emacs)     ; emacs
    data-directory)
   ((fboundp 'locate-data-directory)    ; emacsens (xemacs, etc.)
    (locate-data-directory "ps-print"))
   (t                                   ; don't know what to do
    nil))                               ; I THINK IT SHOULD GIVE AN ERROR!!
  "*Directory where it's located the PostScript prologue file used by ps-print.
By default, this directory is the same as in the variable `data-directory'."
  :type 'directory
  :group 'ps-print-miscellany)


Does this fix the loading order problem with X-Symbol?


Vinicius




reply via email to

[Prev in Thread] Current Thread [Next in Thread]