bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Gnus %u summary-line-format changes hoses my instance


From: Galen Boyer
Subject: Gnus %u summary-line-format changes hoses my instance
Date: 06 Jan 2002 22:27:08 -0800
User-agent: Gnus/5.09 (Gnus v5.9.0) Emacs/21.1

This bug report will be sent to the Free Software Foundation,
not to your local site managers!
Please write in English, because the Emacs maintainers do not have
translators to read other languages for them.

Your bug report will be posted to the address@hidden mailing list,
and to the gnu.emacs.bug news group.

In GNU Emacs 21.1.1 (i386-mingw-nt5.0.2195)
 of 2001-10-22 on GALEN
configured using `configure --with-gcc (2.95)'
Important settings:
  value of $LC_ALL: nil
  value of $LC_COLLATE: nil
  value of $LC_CTYPE: nil
  value of $LC_MESSAGES: nil
  value of $LC_MONETARY: nil
  value of $LC_NUMERIC: nil
  value of $LC_TIME: nil
  value of $LANG: ENU
  locale-coding-system: iso-latin-1
  default-enable-multibyte-characters: t

Please describe exactly what actions triggered the bug
and the precise symptoms of the bug:

I was just starting out using the %u format code in the
gnus-summary-line-format.  (I was trying out something new in the
bbdb)

My format was,
(setq gnus-summary-line-format  "%U%R%d%I%([%-20,20f%]%) %s (%~(ignore 1)2t)\n")

All I did was add %u to the front of the string (thinking that
the bbdb was somehow going to take over from there).

It became
(setq gnus-summary-line-format  "%u%U%R%d%I%([%-20,20f%]%) %s (%~(ignore 
1)2t)\n")

I then got the error

Debugger entered--Lisp error: (void-function gnus-user-format-function-%)
  (gnus-user-format-function-% gnus-tmp-header)

Okay, fine.  So, I then go back to my gnus and remove the %u
bringing it back to the original.  I then reread the init file.
Now, trying to enter the group I get the same error as before.

Debugger entered--Lisp error: (void-function gnus-user-format-function-%)
  (gnus-user-format-function-% gnus-tmp-header)

I then shut down Gnus, as my next recourse.  When I start it back
up again and enter a group, all of my colors are gone.  I now
shut down Emacs.

Recent input:
<return> I t SPC b e c a o m <backspace> <backspace>
m e w <backspace> <return> C-y C-o C-p M-f M-f M-f
M-f M-f C-f C-f C-f % u C-n C-k C-k C-n M-h C-x f C-n
C-n C-n C-n C-n C-p C-e <backspace> SPC b r i n g i
n g SPC i t SPC a <backspace> b a c k SPC t o SPC t
h e SPC r <backspace> p o r <backspace> <backspace>
<backspace> o r i g i n a l . SPC SPC I S-SPC t h e
n <menu-bar> <help-menu> <report-emacs-bug>

Recent messages:
 [2 times]
Mark set
Updating buffer list...done
Commands: m, u, t, RET, g, k, S, D, Q; q to quit; h for help
Mark set
Wrote c:/emacs/home/.gnus
Mark set [4 times]
Auto-saving...done
Mark set [2 times]
Loading emacsbug...done

--
Galen deForest Boyer
Sweet dreams and flying machines in pieces on the ground.




reply via email to

[Prev in Thread] Current Thread [Next in Thread]