bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Gnus %u summary-line-format changes hoses my instance


From: ShengHuo ZHU
Subject: Re: Gnus %u summary-line-format changes hoses my instance
Date: Sun, 06 Jan 2002 23:19:28 -0500
User-agent: Gnus/5.090005 (Oort Gnus v0.05) Emacs/21.1.50 (i686-pc-linux-gnu)

The following message is a courtesy copy of an article
that has been posted to gnu.emacs.bug as well.

address@hidden (Galen Boyer) writes:

[...]

> All I did was add %u to the front of the string (thinking that
> the bbdb was somehow going to take over from there).
>
> It became
> (setq gnus-summary-line-format  "%u%U%R%d%I%([%-20,20f%]%) %s (%~(ignore 
> 1)2t)\n")
>
> I then got the error
>
> Debugger entered--Lisp error: (void-function gnus-user-format-function-%)
>   (gnus-user-format-function-% gnus-tmp-header)

It suppose to use %ub or %uB for bbdb.

> Okay, fine.  So, I then go back to my gnus and remove the %u
> bringing it back to the original.  I then reread the init file.
> Now, trying to enter the group I get the same error as before.
>
> Debugger entered--Lisp error: (void-function gnus-user-format-function-%)
>   (gnus-user-format-function-% gnus-tmp-header)
>
> I then shut down Gnus, as my next recourse.  When I start it back
> up again and enter a group, all of my colors are gone.  I now
> shut down Emacs.

The format is cache in .newrc.eld. You can fix it by removing the line
of gnus-format-specs, or (setq gnus-format-specs nil).

ShengHuo



reply via email to

[Prev in Thread] Current Thread [Next in Thread]