bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

find-grep-dired


From: Adam P.
Subject: find-grep-dired
Date: Wed, 9 Jan 2002 19:58:21 +0100 (CET)

This bug report will be sent to the Free Software Foundation,
not to your local site managers!
Please write in English, because the Emacs maintainers do not have
translators to read other languages for them.

Your bug report will be posted to the address@hidden mailing list,
and to the gnu.emacs.bug news group.

In GNU Emacs 21.1.1 (i386-msvc-windows98.2222)
 of 2001-10-22 on buffy
configured using `configure --with-msvc (12.00)'
Important settings:
  value of $LC_ALL: nil
  value of $LC_COLLATE: nil
  value of $LC_CTYPE: nil
  value of $LC_MESSAGES: nil
  value of $LC_MONETARY: nil
  value of $LC_NUMERIC: nil
  value of $LC_TIME: nil
  value of $LANG: enu
  locale-coding-system: iso-latin-1
  default-enable-multibyte-characters: t

Please describe exactly what actions triggered the bug
and the precise symptoms of the bug:

The problem concerns using find-grep-dired under from NTEmacs 21.1.1
running under Windows98.  The shell command that this normally invokes
contains slashes ('\'), while only the version without slashes works.
The email below, citing my posting to the help-emacs-windows mail list
explains the fix that worked for me.

What probably matters is that I'm using (the latest) 'find' and 'ls'
versions from Cygwin.

----------------------------------------------------------------------
From: "Michael R. Wolf" <address@hidden>
Subject: Re: (no subject)
To: address@hidden
Date: 08 Jan 2002 19:28:30 -0500

address@hidden (Adam P.) writes:

> > Does anyone have the proper settings for using bash under 21.x?,A (B I've 
> > tried using
> > find-grep-dired, with similar, unsatisfactory results as reported by 
> > Christine.
> > Thanks in advance to all who respond.
> 
> What worked for me was putting this in .emacs:
> 
> (setq find-ls-option '("-exec ls -ld {} ;" . "-ld"))  ; no "\\;"!
> 
> and, alas, modifying the source of find-dired.el in the following way:
> 
> ...in defun find-dired (dir args):
> 
>                        (concat "( " args " ) "))
> ;WAS:                  (concat "\\( " args " \\) "))
> 
> ...in defun find-grep-dired (dir args):
> 
>                     args " {} ; ")))
> ;WAS:               args " {} \\\; ")))

This looks like it's a bug report waiting to get filed
(along with a diff or this posting) on gnu.emacs.bug!
----------------------------------------------------------------------

Recent input:
[Doesn't matter for this bug.]

Recent messages:
[Don't matter for this bug.]




reply via email to

[Prev in Thread] Current Thread [Next in Thread]