bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

font not used by emacs


From: Joseph Patterson
Subject: font not used by emacs
Date: Fri, 11 Jan 2002 11:36:07 -0500

Subject: font not used by emacs
To: address@hidden
Reply-to: address@hidden
CC: joseph
FCC: ~/rmail
-text follows this line--
This bug report will be sent to the Free Software Foundation,
not to your local site managers!
Please write in English, because the Emacs maintainers do not have
translators to read other languages for them.

Your bug report will be posted to the address@hidden mailing list,
and to the gnu.emacs.bug news group.

In GNU Emacs 21.1.1 (sparc-sun-solaris2.7, X toolkit)
 of 2001-12-22 on earth
configured using `configure  sparc-sun-solaris2.7 
--x-libraries=/usr/openwin/lib:/usr/openwin/lib:/lib:/usr/lib 
--prefix=/lfs/joseph/gnu/emacs-21.1 
--exec-prefix=/lfs/joseph/gnu/emacs-21.1/sun57 --with-x-toolkit=athena'
Important settings:
  value of $LC_ALL: nil
  value of $LC_COLLATE: nil
  value of $LC_CTYPE: nil
  value of $LC_MESSAGES: nil
  value of $LC_MONETARY: nil
  value of $LC_NUMERIC: nil
  value of $LC_TIME: nil
  value of $LANG: C
  locale-coding-system: nil
  default-enable-multibyte-characters: t

Please describe exactly what actions triggered the bug
and the precise symptoms of the bug:



When I run "emacs -fn oct" where emacs is a version 21.1 and oct is a
custom font from the included gzipped tar file custom.tar.gz, I find
very strange behavior.  The oct font is a large and bold style font.
The oct font is used by emacs for the File Edit etc menus at the top,
but it is treated as an illegal font for the purposes of the window
buffer contents.  The windows default to some proportional font that
is unusable.

When I run "emacs -fn oct" where emacs is a version 20.7 and oct is
the same as above, all works well and the oct font is used in all
windows.

I thought that perhaps this was caused by my creating a font that
didn't follow all the conventions in font design.  But now I have
reason to think otherwise and suspect emacs-21.1 to need a fix.
The reason for this is that I got a copy of the tool pfaedit from
pfaedit.sourceforge.net and loaded the oct font into pfaedit.  Then
I generated the oct font from pfaedit as a bdf file.  I then put
the bdf file in a font directory on solaris, created a fonts.alias 
file, and ran mkfontdir to create a fonts.dir file.  This pfaedit
generated version of oct serves solaris just fine and xterms are
created using oct font satisfactorily.  But, emacs-21.1 behaves
the same way with the pfaedit generated oct font and with my
original oct font.

Please see if you observe the same behavior and might be willing to
make some change to render oct font usable.


Recent input:
<help-echo> <help-echo> <help-echo> <help-echo> <help-echo> 
<help-echo> <help-echo> <help-echo> <help-echo> <help-echo> 
<help-echo> <help-echo> <menu-bar> <files> <make-frame> 
<help-echo> <help-echo> <help-echo> <help-echo> <help-echo> 
<help-echo> <help-echo> <help-echo> <help-echo> <menu-bar> 
<files> <make-frame-on-display> C-g <help-echo> <help-echo> 
<help-echo> <help-echo> <help-echo> <help-echo> <help-echo> 
<help-echo> <help-echo> <help-echo> <help-echo> <help-echo> 
<help-echo> <help-echo> <help-echo> <help-echo> <help-echo> 
<help-echo> <menu-bar> <help-menu> <report-emacs-b
ug>

Recent messages:
Loading regexp-opt...done
Loading zimmextra (source)...done
Loading jtpsrcmode...done
Loading time...done
Loading vhdl-mode...
Loading mule-util...done
Loading vhdl-mode...done
For information about the GNU Project and its goals, type M-? C-p.
Quit
Loading emacsbug...done

Attachment: octfont.tar.gz
Description: Binary data


reply via email to

[Prev in Thread] Current Thread [Next in Thread]