bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Colon confuses emacs: Emacs thinks colon is another host..


From: Deepak Goel
Subject: Colon confuses emacs: Emacs thinks colon is another host..
Date: Fri, 1 Feb 2002 13:09:34 -0500 (EST)

Emacs remote-editing facility using a colon is nice and powerful. 

The problem is that there seems to be no way for emacs to access a
*local* directory-name if the name happens to end in a colon.

To see what i am saying, go to the / of your unix/linux filesystem and
do a "mkdir tmp:"..  A directory called tmp: is duly created. Now drop
some file into it.   Now there seems to be no way for emacs to list
the contents of the tmp: directory. 

Try C-x d /tmp:/ and it asks you for passwords. :(

One would think that backslashing would make emacs interpret the :
literellay but that doesn't work.. understandably so, because \ is
used in windows..

Okay, so we give up on trying to specify a valid name ourselves.. and
we let emacs do it..  We do a C-x d on / and list its contents.. then
we go to tmp:/ and hit RET..  this time emacs should know what it is
doing right?  Because it itself listed tmp: as tmp:/... But no, it
again starts asking for for a password..

My suggestion: 
i think there's an easy win-win option..   IF the colon is doubled,
then emacs should interpret it literally.. Thus, to view the
contents, one should do C-x d /tmp:: and emacs should not ask you for
passwords.




This bug report will be sent to the Free Software Foundation,
not to your local site managers!
Please write in English, because the Emacs maintainers do not have
translators to read other languages for them.

Your bug report will be posted to the address@hidden mailing list,
and to the gnu.emacs.bug news group.

In GNU Emacs 21.1.2 (sparc-sun-solaris2.6, X toolkit, Xaw3d scroll bars)
 of 2001-10-30 on ratbert.eng.umd.edu
configured using `configure  --prefix=/usr/local/gnu 
--infodir=/usr/local/gnu/info/emacs-21.1 --with-kerberos --with-x 
--with-x-toolkit=yes --with-xpm --with-jpeg --with-tiff --with-gif --with-png'
Important settings:
  value of $LC_ALL: nil
  value of $LC_COLLATE: nil
  value of $LC_CTYPE: nil
  value of $LC_MESSAGES: nil
  value of $LC_MONETARY: nil
  value of $LC_NUMERIC: nil
  value of $LC_TIME: nil
  value of $LANG: nil
  locale-coding-system: nil
  default-enable-multibyte-characters: t

Please describe exactly what actions triggered the bug
and the precise symptoms of the bug:




Recent input:
[ D SPC a d i t y a SPC , SPC d h SPC C-x 1 C-c C-c 
n n n y s s ESC [ B ESC [ B ESC [ B ESC [ B ESC [ B 
ESC [ B ESC [ A g s s s ESC [ B ESC [ B ESC [ B ESC 
[ B ESC [ B ESC [ B ESC [ B C-s b u g ESC [ B ESC [ 
A ESC x r e p o r t - e m a c s - b u g RET

Recent messages:
Opening nnfolder server on archive+nnfolder+archive:orders...

Opening nnfolder server on archive+nnfolder+archive:sent-mail-gnus...

Opening nnfolder server on archive+nnfolder+archive:sss...

Checking new news...done
(No changes need to be saved) [3 times]
Mark saved where search started
Loading emacsbug...done



reply via email to

[Prev in Thread] Current Thread [Next in Thread]