bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Cannot change font using options menu if .emacs has a font


From: Debian User
Subject: Cannot change font using options menu if .emacs has a font
Date: Tue, 19 Mar 2002 08:33:28 -0800

This bug report will be sent to the Free Software Foundation,
not to your local site managers!
Please write in English, because the Emacs maintainers do not have
translators to read other languages for them.

Your bug report will be posted to the address@hidden mailing list,
and to the gnu.emacs.bug news group.

In GNU Emacs 21.1.1 (i386-debian-linux-gnu, X toolkit, Xaw3d scroll bars)
 of 2001-12-06 on raven, modified by Debian
configured using `configure  i386-debian-linux-gnu --prefix=/usr 
--sharedstatedir=/var/lib --libexecdir=/usr/lib --localstatedir=/var/lib 
--infodir=/usr/share/info --mandir=/usr/share/man --with-pop=yes --with-x=yes 
--with-x-toolkit=athena --without-gif'
Important settings:
  value of $LC_ALL: nil
  value of $LC_COLLATE: nil
  value of $LC_CTYPE: nil
  value of $LC_MESSAGES: nil
  value of $LC_MONETARY: nil
  value of $LC_NUMERIC: nil
  value of $LC_TIME: nil
  value of $LANG: C
  locale-coding-system: nil
  default-enable-multibyte-characters: t

Please describe exactly what actions triggered the bug
and the precise symptoms of the bug:

Tim Cross wrote in gnu.emacs.help:

If I start emacs 21 and either have no .emacs file or use the -q
switch I can use the shift+mouse-2 combination to bring up the font
menu and choose either from misc or courier fonts and various
sizes. All works as expected. 

However, as soon as I create a .emacs file, attempting to change the
font type or size has absolutely no effect. All that happens is the
screen expands briefly and then contracts back to its current
operating size and fonts do not change. 

I noticed this because I originally started emacs 21, selected a font
I liked via the font menu and then saved the default font settings via
customize so that that would be my initial font when starting
emacs21. Later, I wanted to change to a smaller font so that I could
easily display a file with very long lines and I found the font menu
had no effect. 

I;ve noticed this on two systems running Debian and don't know if its
specific to the debian version of emacs21 or a more general weirdness
common to many installaitons on various platforms. 

And I replied:

I've had the exact same symptoms, running emacs21 on debian
woody. Another (perhaps related) problem is that when I try to change
faces in the middle of a document (e.g. default to bold) using
control-middle-mouse-button, instead of a change face, I get (for
changing get to bold get) geett. Never had this problem in emacs
20.7.

Recent input:
r e . ) <prior> <prior> <down> <down> <right> <down> 
<down> <down> <right> <right> <right> <right> <right> 
<right> <right> <right> <right> <right> <right> <right> 
<right> <right> <right> <right> <right> <right> <right> 
<right> <right> <right> <right> <right> <right> <right> 
<right> <right> <right> <right> <right> <right> <right> 
<right> <right> <right> <right> <right> <right> <right> 
<right> <right> <right> <right> <right> <right> <right> 
<right> <right> <right> I SPC h a v e SPC <down> <down> 
<down> <down> <down-mouse-1> <mouse-1> <down-mouse-3> 
<mouse-3> <help-echo> <help-echo> <help-echo> <help-echo> 
<help-echo> <help-echo> <help-echo> <help-echo> <help-echo> 
<help-echo> <help-echo> <menu-bar> <edit> <fill> <backspace> 
<help-echo> <help-echo> <help-echo> <help-echo> <help-echo> 
<menu-bar> <help-menu> <report-emacs-bug>

Recent messages:
Loading view...done
Mark set [2 times]
Loading newcomment...done
Auto-saving...done
Mismatched parentheses
Auto-saving...done
Auto-saving...done
call-interactively: Beginning of buffer
Loading emacsbug...done
call-interactively: Text is read-only



reply via email to

[Prev in Thread] Current Thread [Next in Thread]