bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Cannot change font style/size with font menu


From: Tim Cross
Subject: Cannot change font style/size with font menu
Date: Thu, 21 Mar 2002 10:23:29 +1100

This bug report will be sent to the Free Software Foundation,
not to your local site managers!
Please write in English, because the Emacs maintainers do not have
translators to read other languages for them.

Your bug report will be posted to the address@hidden mailing list,
and to the gnu.emacs.bug news group.

In GNU Emacs 21.1.1 (i386-debian-linux-gnu, X toolkit, Xaw3d scroll bars)
 of 2001-12-07 on raven, modified by Debian
configured using `configure  i386-debian-linux-gnu --prefix=/usr 
--sharedstatedir=/var/lib --libexecdir=/usr/lib --localstatedir=/var/lib 
--infodir=/usr/share/info --mandir=/usr/share/man --with-pop=yes --with-x=yes 
--with-x-toolkit=athena --without-gif'
Important settings:
  value of $LC_ALL: nil
  value of $LC_COLLATE: nil
  value of $LC_CTYPE: 
  value of $LC_MESSAGES: nil
  value of $LC_MONETARY: nil
  value of $LC_NUMERIC: nil
  value of $LC_TIME: nil
  value of $LANG: C
  locale-coding-system: nil
  default-enable-multibyte-characters: nil

Please describe exactly what actions triggered the bug
and the precise symptoms of the bug:

Attempting to change the font style/size with the font menu accessed
via shift+mouse-1 has no effect if the user has a ~/.emacs. With no
~/.emacs or if you start emacs with -q, then the font menu works as
expected. e.g. 

emacs & -- font menu does not have any effect
emacs -q -no-site-file -- font menu works as expected
emacs --no-site-file -- font menu does not work
emacs -q -- font menu works as expected. 

I have found this happens even if the only values in the .emacs file
are lines added by customize (ie no user added code, only emacs added
code). 

This has been observed on two different systems running emacs 21. I
posted this to the gnu.emacs.help newsgroup and a number of people
reported the same behavior on different platforms including w2k,
solaris and true 64. 

When attempting to change the font from courier -> misc or misc ->
courier or change the font size, all that happens is the screen
flashes, jumps to a larger size for a brief flash and then just
returns to its same size and font - i.e. no effect. 

Tim

Recent input:
d SPC v i a SPC s h i t <backspace> f t _ <backspace> 
+ l e f t - m <backspace> <backspace> <backspace> <backspace> 
<backspace> <backspace> m o u s e - 1 SPC h a s SPC 
n o SPC e f f e c t <up> <down> SPC i f SPC t h SPC 
<backspace> e SPC u s e r SPC h a s SPC a SPC ~ / . 
e m a c s SPC f i l e . SPC C-x k <return> C-x 1 <S-down-mouse-1> 
<help-echo> <help-echo> <help-echo> <help-echo> <menu-bar> 
<help-menu> <report-emacs-bug>

Recent messages:
End of message 23 from address@hidden
Deleted messages expunged.
Quitting...
Stuffing attributes...
Saving...
Saving file /home/tcross/Mail/INBOX...
Wrote /home/tcross/Mail/INBOX

Loading emacsbug...done
Deleted all other windows


-- 
Tim Cross                                       E-Mail: address@hidden
Analyst/Programmer                               Phone: 6773 3210
Applications Group                              Mobile: 0412 969193
University of New England
---
find / -iname microsoft -exec rm -rf {} \;



reply via email to

[Prev in Thread] Current Thread [Next in Thread]