bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: `print' does not print


From: David Kaelbling
Subject: Re: `print' does not print
Date: Mon, 25 Mar 2002 09:49:03 -0500

Eli Zaretskii wrote:
> 
> So it is possible that the change which does the damage is the one about
> .got sections, not the fact that file I/O is used instead of mmap.  Could
> you try unexelf.c from v21.2 with the .got sections and see if that makes
> Emacs 21.1 unable to print?
> 
> David, can you help us here and explain why those additions were
> necessary?  Perhaps the new unexelf.c in Emacs 21.2 makes them redundant?

I'm afraid I can't offer much useful input here.  When I first tried
emacs 21 wouldn't bootstrap because the dumped emacs died with a bus
error.  I compared unexelf.c with the one in emacs 20 and the one in
xemacs (both of which work flawlessly), and re-introduced some code that
had been removed.  Afterwards emacs 21 worked, although it is not quite
right: it gives dbx fits, and is subject to runaway memory growth and
sporadic crashes.

I can try to beg time from someone who actually understands the elf file
if that would help.  Maybe whoever removed that code from the previous
versions remembers why?

        David

-- 
David KAELBLING <address@hidden>            Silicon Graphics Computer Systems
1 Cabot Rd, suite 250; Hudson, MA 01749     781.839.2157, fax ...2357



reply via email to

[Prev in Thread] Current Thread [Next in Thread]