[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: address@hidden: Re: emacs 21.2 odd behavior in shell window]

From: Tom Wurgler
Subject: Re: address@hidden: Re: emacs 21.2 odd behavior in shell window]
Date: Thu, 4 Apr 2002 10:57:12 -0500 (EST)

Recently Richard Stallman <address@hidden> wrote:

> Date: Mon, 1 Apr 2002 16:21:08 -0700 (MST)
> From: Richard Stallman <address@hidden>
> CC: address@hidden, address@hidden
> Reply-to: address@hidden
>     Now when I hit ^C^C in emacs 21.2, I get nothing.
>     I then hit ^H^C ^C^C and it says it is bound to comint-interupt-subjob.
>     I then type esc-: (comint-interupt-subjob) and the program is sucessfully
>     aborted. 
> Please try redefining comint-interupt-subjob to run interpreted and
> put (debug) into it at the beginning.  Then try stepping through it
> and see what it does.

Here is what I tried.  

I brought comint.el into a buffer, searched for "defun comint-interrupt-subjob"

Below the (interactive) I added a (debug) and set the region around the defun,
then did eval-region.

I then did ^C^C and stepped through no problem and eventually aborted the
program in the shell.  So I started the shell program again and did ^C^C.  When
the debug started I just hit C, it completed the abort just fine.

So I took out the debug line and eval'ed the defun again.  Now ^C^C aborted
the program just fine.

So I got out of emacs totally, restarted, tried the ^C^C again and it didn't

So I brought comint.el into a buffer again, eval'ed just comint-interrupt-subjob
without adding or changing anything else.  Now ^C^C worked just fine.

Does any of this help?  (Is this what you meant to do when you said to run


reply via email to

[Prev in Thread] Current Thread [Next in Thread]