bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Emacs 21.2 and termcap problem


From: Eli Zaretskii
Subject: Re: Emacs 21.2 and termcap problem
Date: Mon, 13 May 2002 13:52:30 +0300 (IDT)

On 13 May 2002 address@hidden wrote:

> I have just compiled Emacs 21.2 on my home Woody Debian computer. I
> have done everything "as usual" (I started to compile Emacs with some
> pretest version); there was no substantial changes of my system in the
> meantime. However, 21.2 does not start reporting
> 
>       Cannot open termcap database file  
> 
> Does this mean that Emacs really tries to open termcap file while my
> system uses terminfo? 

Yes, it means Emacs tries to open termcap.  You can see the message in 
term.c, together with the #ifdef that conditions it.

> Anyway, what do you recommend me to do?

I'd suggest to make sure you have the latest version of ncurses installed 
and visible to the Emacs build at configure time.  Old versions of 
ncurses sometimes dupe the configure script into thinking your system 
doesn't support terminfo.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]