bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Bug in ange-ftp on NetBSD


From: Jesse Sheidlower
Subject: Bug in ange-ftp on NetBSD
Date: Sat, 18 May 2002 19:47:33 -0400
User-agent: Mutt/1.3.28i

I was having some problems using ange-ftp to get to a
NetBSD system, and after a trying a bunch of different
things, eventually asked my sysadmin, who replied:

-----
The problem is that ange-ftp uses a nonstandard way of getting
directory information that doesn't work with NetBSD's ftpd.  This
is an open issue with NetBSD - it's in their bug database as:

  http://www.netbsd.org/cgi-bin/query-pr-single.pl?number=12667

The problem is that ange-ftp sends "ls -al <directory>" to show directory
contents, which works with most FTP servers but isn't really part
of the protocol.  It became unsupported "by accident" when we
switched to lukemftpd last year, because lukemftpd parses the "ls"
command internally instead of just invoking a subshell to call /bin/ls.

It would be nice if someone fixed ange-ftp to be a little smarter
about this stuff.  It would work fine if they left off the directory
name (i.e. chdir'd to the directory before sending "ls -al").  Is the
package still being maintained?
-----

So, I hope that this can be fixed for future versions of GNU Emacs.
In the meantime, could you recommend to someone entirely ignorant
of LISP a way of patching this so it works?

Thanks, hope this helps.

Jesse Sheidlower
<address@hidden>



reply via email to

[Prev in Thread] Current Thread [Next in Thread]