bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: RMAIL doesn't always recognize rmail-mime-charset-pattern


From: David Kuehling
Subject: Re: RMAIL doesn't always recognize rmail-mime-charset-pattern
Date: 19 May 2002 15:09:58 +0200

>>>>> "Eli" == Eli Zaretskii <address@hidden> writes:

> Do you still have the original mailbox retrieved by pop3?

Today I made a copy of my inbox file, before using Emacs' pop3 mail
retrieval.  The bug is now reproducable, when receiving that mail box
via pop3 (2nd mail in the mailbox file).  But it won't occur, when I use
C-u g savedmailbox <Ret>.  That's cool!

And I just discovered another mysterious bug.  The last mailinglist mail
in the mailbox (from debian-japanese) contains a 

Content-Type: TEXT/PLAIN; charset=iso-8859-1

header, although its contents are obviously iso-2022-jp (7bit) encoded.
When receiving the mailbox via pop3, the japanese characters in the mail
show up correctly, and an

X-Coding-System: iso-2022-jp-unix

header is generated.  How can that happen?  The same mail, however, read
via C-u g ... will be decoded as iso-8859-1 (as it should be).

I attach the full mailbox: savedmailbox.gz.

David K├╝hling
-- 
GnuPG public key: http://user.cs.tu-berlin.de/~dvdkhlng/dk.gpg
Fingerprint: B17A DC95 D293 657B 4205  D016 7DEF 5323 C174 7D40

Attachment: savedmailbox.gz
Description: Binary data


reply via email to

[Prev in Thread] Current Thread [Next in Thread]