bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Zone


From: Jason Rumney
Subject: Re: Zone
Date: Thu, 13 Jun 2002 20:39:15 +0000 (UTC)
User-agent: Gnus/5.09 (Gnus v5.9.0) Emacs/21.3.50

address@hidden (Thien-Thi Nguyen) writes:

> "Almer S. Tigelaar" <address@hidden> writes:
> 
>    Using : GNU Emacs 21.1.1 (i386-msvc-nt5.0.2195) of 2002-03-19 on buffy
> 
>    I noticed an error in the "zone" package, it seems that the argument to
>    "zone-when-idle" is not in seconds but in 1/10ths of a second.
>    Reproduction:
>    try "M-x zone-when-idle 180"
>    Sit back and don't touch anything, notice that it zones out after 18
>    seconds, not 180 as the documentation suggests.
> 
>    The "run-with-idle-timer" function does not exhibit this malfunction which
>    suggests that the problem lies within the zone package itself.
> 
> this may be true but it's difficult to tell from the information given.
> 
> i suggest trying a more recent emacs.  if the problem persists, could you
> write a small test case using run-with-idle-timer and describe its behavior
> more precisely?

I thought I had reproduced the problem with zone in 21.2 on Windows
2000, and current CVS HEAD on GNU/Linux.  But it turns out from
studying the code that my testing methodology was at fault.

My patience does not stretch to 3 minutes, so I first tried 20
seconds.  When that worked I tried again with 180, and thought I was
seeing this bug.  But in fact, calling zone-when-idle a second time
is a no-op.  This was somewhat unexpected, I expected the timer
to be changed to the new value.

--
Jason Rumney



reply via email to

[Prev in Thread] Current Thread [Next in Thread]