bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

unable to compile CVS version of emacs


From: John H Palmieri
Subject: unable to compile CVS version of emacs
Date: Fri, 14 Jun 2002 13:19:08 -0700

In GNU Emacs 21.2.2 (alphaev5-dec-osf5.1, X toolkit)
 of 2002-04-03 on goedel1.math.washington.edu
configured using `configure  --prefix=/scratch/palmieri'
Important settings:
  value of $LC_ALL: nil
  value of $LC_COLLATE: nil
  value of $LC_CTYPE: nil
  value of $LC_MESSAGES: nil
  value of $LC_MONETARY: nil
  value of $LC_NUMERIC: nil
  value of $LC_TIME: nil
  value of $LANG: nil
  locale-coding-system: nil
  default-enable-multibyte-characters: t


I downloaded the current CVS version of Emacs from savannah, ran
`./configure --prefix=/scratch/palmieri', then typed `make'.  This
gave me the error

  Essential Lisp files seem to be missing.  You should either
  do `make bootstrap' or create `lisp/abbrev.elc' somehow.

So I typed `make bootstrap'.  This ran for a while, and then dumped
core:

./temacs --batch --load loadup bootstrap
Loading loadup.el (source)...
Using load-path (/scratch/palmieri/cvsroot/emacs/lisp 
/scratch/palmieri/cvsroot/emacs/lisp/emacs-lisp 
/scratch/palmieri/cvsroot/emacs/lisp/language 
/scratch/palmieri/cvsroot/emacs/lisp/international)
Loading byte-run (source)...
Loading emacs-lisp/backquote (source)...
Loading subr (source)...

  [snip]

Loading language/japanese (source)...
Loading language/korean (source)...
Loading language/lao (source)...
Loading language/thai (source)...
Loading language/tibetan (source)...
gmake[1]: *** [bootstrap-emacs] Segmentation fault (core dumped)
gmake[1]: Leaving directory `/scratch/palmieri/cvsroot/emacs/src'
gmake: *** [bootstrap-src] Error 2


Here's a backtrace from gdb.  What other information can I provide?


(/<3>emacs/src) [1:13pm]>> gdb ./temacs core
GNU gdb 5.1.1
Copyright 2002 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "alphaev5-dec-osf5.1"...
BFD: Unhandled OSF/1 core file section type 0

BFD: Unhandled OSF/1 core file section type 528

BFD: Unhandled OSF/1 core file section type 0


warning: big endian file does not match little endian target.
Core was generated by `
                       '.
Program terminated with signal 1, Hangup.

warning: Couldn't find general-purpose registers in core file.


warning: Couldn't find general-purpose registers in core file.

#0  0x00000000 in ?? ()
DISPLAY = x69:0.0
TERM = xterm
Breakpoint 1 at 0x120161ba8: file emacs.c, line 6.
Breakpoint 2 at 0x120126a8c: file xterm.c, line 6.
(gdb) 



Questions:
This is for the version that I obtained from CVS by running
`cvs update' at 1:00 pm PDT, 2002/06/14.  Is there a better way to
specify a version?

Should I try to avoid the bootstrapping process by byte-compiling the
files in the lisp directory using a working copy of Emacs 21.2.2?

Finally, is this the right place to report problems with the CVS
version of Emacs?

-- 
J. H. Palmieri
Dept of Mathematics, Box 354350    mailto:address@hidden
University of Washington           http://www.math.washington.edu/~palmieri/
Seattle, WA 98195-4350



reply via email to

[Prev in Thread] Current Thread [Next in Thread]