[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Emacs - cannot connect to X server

From: Matt Muggeridge
Subject: Emacs - cannot connect to X server
Date: Thu, 20 Jun 2002 02:01:37 GMT

Environment: emacs on Tru64 UNIX V5.1 and Digital OSF1 V4.0, connecting to
my PC X-Server (Xcursion) across a wide-area cable connection.

When attempting to start emacs, I see:

    Emacs   WAN Result          LAN Result
   -------   -----------------   -----------------
    20.7      always succeeds    always succeeds
    21.1      mostly succeeds     always succeeds
    21.2      rarely succeeds      always succeeds

When it fails, the message displayed is:

 emacs: Cannot connect to X server xx.xx.xx.xx:0.0.
 Check the DISPLAY environment variable or use `-d'.
 Also use the `xhost' program to verify that it is set to permit
 connections from your machine.

It seems to be independent of the OS, as I see the same result on Tru64 UNIX
V5.1 and Digital OSF1 V4.0.  It also seems to be independent of my PC, as
I've tried it on one running Windows/ME and another running W2K.

All other X-applications I have tried succeed, even when emacs fails
repeatedly.  E.g. I can successfully run "xeyes", "xterm", "xclock",
"emacs-20.7".  This problem is limited to the versions of emacs above.

I do not understand how emacs connects to the X server, but I am suspicious
of timeouts.  Could it be that emacs does not wait long enough to establish
an X-session over a slow link?

Thanks for any feedback.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]