[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


From: dean
Subject: ebrowse-tags-complete-symbol
Date: Tue, 16 Jul 2002 12:46:42 -0700 (PDT)

I'm looking for some help with the ebrowse-tags-complete-symbol function.
Everything within ebrowse works great except this one function (the main
reason I wish to use ebrowse).

This is a copy of typical error message I get when trying to run the
function (normally done from C-c b TAB):

 all-completions: Invalid function: #<hash-table 'equal nil 3/65

The numbers change each time I run it (of course) but the format is the same.

The type of code I'm trying to work with is:


class A
  int reallyLongSillyName( void) const;

bool someReallyImportantFunction( A &a)
  // check all imputs
     // ...
  // now do work

  return true;


My understanding of ebrowse-tags-complete-symbol is that if I have the
insertion point following 'a.really' and run it, then I should get a list of
possible results. No?

I'm running a stock RH 7.3 install on a laptop, in which everthing else
seems to be working. Even the other portions of ebrowse work (ie. I can
build a class tree & find symbols) it's just this one element missing.

What I've done to fix this:
  1) tried search for the error in google, but with no results (too
     much noise)
  2) dl'd the newest ebrowse.el from CVS and installed it to my
     .emacs-include dir (were I put my personal emacs scripts)
  3) installed the byte compiled ebrowse.elc into my lisp/progmodes dir

Still no go. Am I missing something? Is this just a problem with my RH
install (and RH has not released a fix for this yet AFAIK)? Any help would
 be welcome.

Dean Giberson

reply via email to

[Prev in Thread] Current Thread [Next in Thread]