bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: problems porting .emacs to NTemacs


From: Stefan Monnier <address@hidden>
Subject: Re: problems porting .emacs to NTemacs
Date: 25 Aug 2002 15:15:09 -0400
User-agent: Gnus/5.09 (Gnus v5.9.0) Emacs/21.3.50

The following message is a courtesy copy of an article
that has been posted to gnu.emacs.help as well.

>>>>> "Michael" == Michael Soulier <address@hidden> writes:
> Stefan Monnier  wrote:
>>> '(default ((t (:stipple nil :background "#e5e5e5" :foreground
>>> "black" :inverse-video nil :box nil :strike-through nil :overline
>>> nil :underline nil :slant normal :weight normal :height 87 :width
>>> normal :family "adobe-courier"))))
>> Options => Enter Debugger on Error
> Ok. This is a piece of the backtrace. It would seem that face-spec-choose
> has run amock, but I'm guessing.
[...]
> Debugger entered--Lisp error: (error "Variable binding depth exceeds
> max-specpdl-size")
>    face-spec-choose((((... ...) (:foreground "red")) ((... ...) (:foreground 
> "red" :bold t)) ((... ...) (:foreground "Pink" :bold t)) (t (:inverse-video t 
> :bold t))) #<frame address@hidden 0x144fc00\ >)
>    face-spec-set(font-lock-warning-face (((... ...) (:foreground "red")) 
> ((... ...) (:foreground "Red" :bold t)) ((... ...) (:foreground "Pink" :bold 
> t)) (t (:inverse-video t :bold t))) #<frame address@hidden 0x144fc00\ >)
>    face-set-after-frame-default(#<frame address@hidden 0x144fc00\ >)
>    internal-set-lisp-face-attribute(default :family "adobe-courier" #<frame 
> address@hidden 0x144fc00\ >)
>    set-face-attribute(default #<frame address@hidden 0x144fc00\ > :family 
> "adobe-courier")
>    face-spec-set(default ((t (:stipple nil :background "#e5e5e5" :foreground 
> "black" :inverse-video nil :box nil :strike-through nil :overline nil 
> :underline nil :slant normal :weight normal :height 87 :width normal :family 
> "adobe-courier"))) #<frame address@hidden 0x144fc00\ >)
>    face-set-after-frame-default(#<frame address@hidden 0x144fc00\ >)

It seems that when set-face-attribute is called on the `default' face to
change some font-related property (the family in this case), it does a
`modify-frame-parameter' to change its `font' setting which in turn then calls
`face-set-after-frame-default' to refresh all the faces which in turns
tries to use the `default' setting which changes the `family' again, ...

Looks like a bug.  Does it also happen under Xwindow ?
Please reply to gnu.emacs.bug.


        Stefan




reply via email to

[Prev in Thread] Current Thread [Next in Thread]