[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

metamail commands don't work

From: Akop Pogosian
Subject: metamail commands don't work
Date: Mon, 7 Oct 2002 19:26:10 -0700 (PDT)

This bug report will be sent to the Free Software Foundation,
not to your local site managers!
Please write in English, because the Emacs maintainers do not have
translators to read other languages for them.

Your bug report will be posted to the bug-gnu-emacs@gnu.org mailing list,
and to the gnu.emacs.bug news group.

In GNU Emacs 21.2.1 (sparc-sun-solaris2.6, X toolkit)
 of 2002-03-27 on gold
configured using `configure  --prefix=/local/sol/2.6/depot/emacs-21.2'
Important settings:
  value of $LC_ALL: nil
  value of $LC_COLLATE: nil
  value of $LC_CTYPE: nil
  value of $LC_MESSAGES: nil
  value of $LC_MONETARY: nil
  value of $LC_NUMERIC: nil
  value of $LC_TIME: nil
  value of $LANG: nil
  locale-coding-system: nil
  default-enable-multibyte-characters: t

Please describe exactly what actions triggered the bug
and the precise symptoms of the bug:

In the older versions of emacs, if you run M-x metamail-interpret-body,
the metamail program would be run to inspect the message body and
perform the appropriate actions according to how the mailcap file setup
(e.g. usually extract and attachment and launch some program to view it).
Starting with emacs 21.x this command stopped working. When I run M-x
metamail-interpret-body, or M-x metamail-buffer, I simply see the
message text scrolling before me and nothing else happens. If I save a
message in a separate file and run metamail on it, it works as
expected, so it is possible that emacs is doing something odd. I
replaced the metamail program with a shell script that saves the file
that's passed to it with arguments somewhere so that emacs doesn't
delete it when metamail returns. I looked at that file and I noticed
that the header "Content-Type: MULTIPART/MIXED;" is missing in it. For
some reason emacs removes it before running metamail. I am getting
this when I run M-x metamail-buffer or M-x metamail-interpret-body.
The absence of this header seems to confuse metamail. I simply see
text scrolling and nothing else happening if I run metamail on that
file from command line. Is this an emacs bug or is there something
that I am doing wrong?

Recent input:
<escape> x m e t a <backspace> <backspace> <backspace> 
<backspace> <help-echo> r e p o r t - e m a c s - b 
u g <return>

Recent messages:
Loading tool-bar...done
Loading image...done
Loading tooltip...done
For information about the GNU Project and its goals, type C-h C-p.
Loading emacsbug...done

reply via email to

[Prev in Thread] Current Thread [Next in Thread]