[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

ispell/aspell misalignment

From: Per Starback
Subject: ispell/aspell misalignment
Date: Mon, 28 Oct 2002 18:16:32 +0100

In GNU Emacs 21.2.1 (i386-redhat-linux-gnu, X toolkit, Xaw3d scroll bars)
 of 2002-09-18 on tempus
configured using `configure  i386-redhat-linux --prefix=/usr --exec-prefix=/usr 
--bindir=/usr/bin --sbindir=/usr/sbin --sysconfdir=/etc --datadir=/usr/share 
--includedir=/usr/include --libdir=/usr/lib --libexecdir=/usr/libexec 
--localstatedir=/var --sharedstatedir=/usr/com --mandir=/usr/share/man 
--infodir=/usr/share/info --with-gcc --with-pop --with-sound'
Important settings:
  value of $LC_ALL: nil
  value of $LC_COLLATE: nil
  value of $LC_CTYPE: sv_SE.ISO8859-1
  value of $LC_MESSAGES: nil
  value of $LC_MONETARY: nil
  value of $LC_NUMERIC: nil
  value of $LC_TIME: nil
  value of $LANG: en_US.iso885915
  locale-coding-system: iso-latin-1
  default-enable-multibyte-characters: t

Please describe exactly what actions triggered the bug
and the precise symptoms of the bug:

1. emacs -q  ispell-bug.tex &

where ispell-bug.tex contains the following:

an orange \ref{one-dictionary}

2. M-x ispell-buffer RET
3. SPC (to leave "grux" unchanged)
Message: Spell-checking done
4. M-x ispell-buffer RET
5. SPC (to again leave "grux" unchanged)

This yields an error:

ispell-process-line: Ispell misalignment: word `sgml' point 86; probably 
incompatible versions

$ /usr/bin/ispell --version
Ispell compatibility script for Aspell.
Usage: /usr/bin/ispell [options] -a|-l|-v[v]|<file>

This is from aspell- on Red Hat.  If I add

1.5 M-: (setq ispell-program-name "aspell") RET

I still get the same error.

$ aspell --version
@(#) International Ispell Version 3.1.20 (but really Aspell .33.7.1 alpha)

(I haven't tried with a real ispell.)  I expected it to just work
without any errors, at least when I told it to use aspell.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]