[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Bug within desktop-save functionality in OS X port???

From: Sebastian Tennant
Subject: Bug within desktop-save functionality in OS X port???
Date: Tue, 8 Apr 2003 21:20:37 +0100

Operating System: Mac OSX 'Jaguar' 10.2.4
Emacs version: 21.1.1 (pre-compiled version that ships with Developer Tools)

I believe this is a bug, forgive me if I'm wrong. To try and be as sure as possible I created a brand new user and tried the following sequence from this new home directory:

Launch Terminal (default shell - tcsh)
% emacs
C-x C-f test (enter 'This is a text file' in new buffer)
M-x text-mode
M-x auto-fill-mode
M-x customize-group <RET> desktop
desktop-enable [toggle] non-nil (saving state for future sessions, .emacs created)
M-x desktop-save <RET> (selecting home directory, .emacs.desktop created)
C-x C-c <y RET> (writing file 'test' to disk)
% emacs 'test' read & buffer created but in FUNDAMENTAL mode, auto-fill mode preserved.

I've tried re-ordering this sequence, ie, 'desktop-enabling' before setting the major & minor mode but to cut a long story short, the major mode text-mode is simply not being preserved, even when starting emacs completely from scratch, i.e., in a whole new home directory. I have posted pleas for help at help-gnu-emacs without success. The best explanation I've been given so far was that a function involved with restoring the desktop must be crashing and that I should check my *Messages* buffer immediately after start-up, and failing that, disable my .emacs file (effectively starting from scratch) and see if the problem persisted. I have done both, (no relevant messages were being shown), and this has lead me to conclude that there must be a bug.

Dying to know what's going on / if it's a bug / if not, what I'm missing / doing wrong.


"War is not the answer..." - Marvin Gaye - 'What's Going On?'

reply via email to

[Prev in Thread] Current Thread [Next in Thread]