bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

x-fixed-font-alist


From: Peter Dyballa
Subject: x-fixed-font-alist
Date: Tue, 22 Jul 2003 15:31:15 +0200
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030401

This bug report will be sent to the Free Software Foundation,
not to your local site managers!
Please write in English, because the Emacs maintainers do not have
translators to read other languages for them.

Your bug report will be posted to the address@hidden mailing list,
and to the gnu.emacs.bug news group.

In GNU Emacs 21.2.1 (i686-pld-linux-gnu, X toolkit, Xaw3d scroll bars)
of 2002-11-07 on ep09
configured using `configure --prefix=/usr --exec-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin --sysconfdir=/etc --datadir=/usr/share --includedir=/usr/include --libdir=/usr/lib --localstatedir=/var --mandir=/usr/share/man --infodir=/usr/share/info --libexecdir=/usr/lib --sharedstatedir=/var --with-gcc --with-pop --with-x-toolkit --with-xpm --with-jpeg --with-tiff --with-gif --with-png i686-pld-linux'
Important settings:
 value of $LC_ALL: nil
 value of $LC_COLLATE: nil
 value of $LC_CTYPE: nil
 value of $LC_MESSAGES: nil
 value of $LC_MONETARY: nil
 value of $LC_NUMERIC: nil
 value of $LC_TIME: nil
 value of $LANG: address@hidden
 locale-coding-system: iso-latin-9
 default-enable-multibyte-characters: nil

Please describe exactly what actions triggered the bug
and the precise symptoms of the bug:

In this GNU Emacs RPM package (for Red Hat 7.2) the list contains for example "-schumacher-clean-medium-r-normal--8-*-*-*-c-50-iso8859-1" although no such font is provided by

XFree86 Version 4.1.0 (Red Hat Linux release: 4.1.0-49) / X Window System
(protocol Version 11, revision 0, vendor release 6510)
Release Date: 2 June 2001

Build Operating System: Linux 2.4.20-2.48smp i686 [ELF]
Build Host: stripples.devel.redhat.com

The clean Schumacher fonts are actually iso646.1991-irv encoded. I'm trying to correct the values and to change the menu's contents in mouse.el/mouse.elc but this does not succeed. Trying to use set-variable in site-init.el too does not succeed.

Here is the error message from GNU Emacs:

Debugger entered--Lisp error: (error "Font not found")
 signal(error ("Font not found"))
 error("Font not found")
mouse-set-font("-schumacher-clean-medium-r-normal--8-*-*-*-c-50-iso8859-1")
 call-interactively(mouse-set-font)

--
Greetings

Pete                                            Nols GES AG
                                               Gervinusstra├če 18-22
(Peter Dyballa)         069-92024┬Ě795           60322 Frankfurt am Main






reply via email to

[Prev in Thread] Current Thread [Next in Thread]