bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Cygwin Bash incompatibility


From: Maslen, David M
Subject: Cygwin Bash incompatibility
Date: Tue, 23 Sep 2003 14:52:17 +1000

--text follows this line--
This bug report will be sent to the Free Software Foundation,
not to your local site managers!
Please write in English, because the Emacs maintainers do not have
translators to read other languages for them.

Your bug report will be posted to the address@hidden mailing list,
and to the gnu.emacs.bug news group.

In GNU Emacs 21.3.1 (i386-msvc-nt5.0.2195)
 of 2003-03-28 on buffy
configured using `configure --with-msvc (12.00)'
Important settings:
  value of $LC_ALL: nil
  value of $LC_COLLATE: nil
  value of $LC_CTYPE: nil
  value of $LC_MESSAGES: nil
  value of $LC_MONETARY: nil
  value of $LC_NUMERIC: nil
  value of $LC_TIME: nil
  value of $LANG: ENA
  locale-coding-system: iso-latin-1
  default-enable-multibyte-characters: t

Please describe exactly what actions triggered the bug
and the precise symptoms of the bug:

I don't seem to be able to use the cygwin bash command in the windows build of 
emacs21.3 I can use the cygwin sh command. Prior to a recent upgrade, bash was 
working. 
 
Below is an email trail I sent to the cygwin list. This would make it seem that 
emacs is the problem. 

I'm using emacs 21.3 not 21.2 so perhaps this is an emacs bug.
GNU Emacs 21.3.1 (i386-msvc-nt5.0.2195) of 2003-03-28 on buffy

Everything else looks the same.

    Cygwin DLL version info:
        DLL version: 1.5.3
        DLL epoch: 19
        DLL bad signal mask: 19005
        DLL old termios: 5
        DLL malloc env: 28
        API major: 0
        API minor: 90
        Shared data: 3
        DLL identifier: cygwin1
        Mount registry: 2
        Cygnus registry name: Cygnus Solutions
        Cygwin registry name: Cygwin
        Program options name: Program Options
        Cygwin mount registry name: mounts v2
        Cygdrive flags: cygdrive flags
        Cygdrive prefix: cygdrive prefix
        Cygdrive default prefix: 
        Build date: Mon Sep 1 13:15:28 EDT 2003
        Shared id: cygwin1S3

I'll report it to the emacs developers as well.

-----Original Message-----
From: Pach Roman (GS-EC/EEP3) * [mailto:address@hidden
Sent: Tuesday, 23 September 2003 2:19 PM
To: Maslen, David M; address@hidden
Subject: AW: Bug in Bash 2.05b.0(13) with nt-emacs


Hello,
I'm working with emacs & bash as well:

 GNU bash, version 2.05b.0(13)-release (i686-pc-cygw
 Copyright (C) 2002 Free Software Foundation, Inc.

 "GNU Emacs 21.2.1 (i386-mingw-nt5.0.2195)"

 Cygwin DLL version info:
     DLL version: 1.5.3
     DLL epoch: 19
     DLL bad signal mask: 19005
     DLL old termios: 5
     DLL malloc env: 28
     API major: 0
     API minor: 90
     Shared data: 3
     DLL identifier: cygwin1
     Mount registry: 2
     Cygnus registry name: Cygnus Solutions
     Cygwin registry name: Cygwin
     Program options name: Program Options
     Cygwin mount registry name: mounts v2
     Cygdrive flags: cygdrive flags
     Cygdrive prefix: cygdrive prefix
     Cygdrive default prefix:
     Build date: Mon Sep 1 13:15:28 EDT 2003
     Shared id: cygwin1S3

I have no problems at all.
Roman

-----Urspr=8fcngliche Nachricht-----
Von: Maslen, David M [mailto:address@hidden
Gesendet: Dienstag, 23. September 2003 06:07
An: address@hidden
Betreff: Bug in Bash 2.05b.0(13) with nt-emacs


Please accept this fairly brief, bug report.

I'm using GNU Emacs 21.3.1 on Windows2000 (not the cygwin build)
I'm using cygwins bash 2.05b.0(13) command as my explicit-shell-command from 
within emacs and have c:\cygwin\bin in my path.

This previously allowed me to use bash as the shell from within emacs.
After an cygwin upgrade, this no longer worked. Bash would start, but I could 
not use any other shell commands (ie. ls) internal bash commands such as 'cd' 
did seem to work.

Changing my explicit-shell-command to be cygwin's sh command  works as bash 
used to. 
Using eshell also seems to be a viable alternative.

I don't subscribe to this list, and am not entirely sure that this is the most 
appropriate place to submit bugs.
If I can provide further information, please contact me directly. Otherwise 
thanks to the cygwin developers for the work they've done so far in providing a 
*nix like environment in the windows wilderness.


Recent input:
<backspace> <backspace> <backspace> <backspace> <backspace> 
<backspace> <backspace> <backspace> <backspace> <backspace> 
<backspace> <backspace> <backspace> <backspace> <backspace> 
<backspace> <backspace> <backspace> <backspace> <backspace> 
C-y <left> <left> <left> <left> <left> <left> <left> 
<left> <left> <left> <left> <left> <left> <left> <left> 
<left> <left> <left> <left> <left> <left> <left> <left> 
<left> <left> <left> <left> <left> <left> <left> <backspace> 
<right> <right> <right> <right> <right> <right> <right> 
<right> <right> <right> <right> <right> <right> <right> 
<right> <right> <right> <right> <right> <right> <right> 
<right> <right> <right> <right> <right> b a <right> 
<right> <right> <right> C-x C-e M-x s h e l l <return> 
l s <return> <help-echo> <menu-bar> <help-menu> <r
eport-emacs-bug>

Recent messages:
Mark set
Saved text from "    Cygwin DLL version info:
        DLL"
Loading emacsbug...done
"bash"
call-interactively: Command attempted to use minibuffer while in minibuffer
Mark set
Auto-saving...done
Mark set
"bash"

--
David Maslen
Solution Designer 
Phone: (03) 8661 3443 





reply via email to

[Prev in Thread] Current Thread [Next in Thread]