bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [h-e-w] Current word on binaries


From: Harald Maier
Subject: Re: [h-e-w] Current word on binaries
Date: Sat, 14 Feb 2004 14:18:24 +0100
User-agent: Gnus/5.110002 (No Gnus v0.2) Emacs/21.3.50 (gnu/linux)

"Eli Zaretskii" <address@hidden> writes:

>> From: Harald Maier <address@hidden>
>> Date: Sat, 14 Feb 2004 10:33:50 +0100
>> >
>> > I tried it too and I found too that something goes wrong. 'emacs -q'
>> > works fine, but when I tried to load my .emacs it displays the 'Emacs
>> > Abort Dialog' and complains that 'A fatal error has occured!'
>> 
>> I did some additional tests and it looks that the problem occurs only
>> if emacs-21.3 is compiled with a latest cygwin gcc. I did two test
>> with the emacs-21.3.tar.gz from March last year and the actual tarball
>> from ftp.gnu.org. On both sources the same happens, so it does not
>> look that something has changed since the compromise of the server.
>> Afterwards I compiled emacs with MSVC and the result is that all works
>> as expected. Currently I have no clue why the problem with gcc
>> happens.
>
> What version of GCC is the one that produces a bad binary?  What does
> "gcc --version" says?
>
> Can someone run Emacs under GDB and see where exactly does it abort?
>
> One possible idea to check is to use lower level of optimizations when
> building Emacs, like -O0 or -O1.  Can someone see if that produces a
> good binary?

It's gcc-3.3.1. I debugged the problem with insight and I got the
following backtrace in insight:

#1  0x01165be7 in w32_abort () at w32fns.c:14239
#2  0x01124db1 in Fbyte_code (bytestr=831842164, vector=1100249856, maxdepth=4) 
at bytecode.c:1710
#3  0x010234a7 in funcall_lambda (fun=1100290880, nargs=0, arg_vector=0x82ecf8) 
at eval.c:2851
#4  0x01022e7b in Ffuncall (nargs=1, args=0x82ecf4) at eval.c:2707
#5  0x01122e57 in Fbyte_code (bytestr=831842132, vector=1100249920, maxdepth=3) 
at bytecode.c:716
#6  0x01021cbc in Feval (form=1367136764) at eval.c:2019


The problem occured with the following command line:

$ emacs -q --no-site-file -l f:/home/maierh/local/elisp/html-helper-mode.el

,----
| ;;; html-helper-mode.el --- Major mode for composing html files.
| ;;; v 3.0.4jolly
`----

html-helper-mode is not the only example where it happens. As I
mentioned before with the current cvs emacs all works fine.

Harald




reply via email to

[Prev in Thread] Current Thread [Next in Thread]