bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

(no subject)


From: Gary
Subject: (no subject)
Date: Fri, 13 Aug 2004 22:56:32 -0700
User-agent: nail 10.6 11/15/03

From: Gary <address@hidden>
To: address@hidden
Subject: block cursor is always a box and never solid
Reply-to: address@hidden

This bug report will be sent to the Free Software Foundation,
not to your local site managers!
Please write in English, because the Emacs maintainers do not have
translators to read other languages for them.

Your bug report will be posted to the address@hidden mailing list,
and to the gnu.emacs.bug news group.

In GNU Emacs 21.3.1 (i586-suse-linux, X toolkit, Xaw3d scroll bars)
 of 2004-04-05 on gray
configured using `configure '--with-gcc' '--with-pop' '--with-system-malloc' 
'--prefix=/usr' '--infodir=/usr/share/info' '--mandir=/usr/share/man' 
'--sharedstatedir=/var/lib' '--libexecdir=/usr/lib' '--with-x' '--with-xpm' 
'--with-jpeg' '--with-tiff' '--with-gif' '--with-png' '--with-x-toolkit=lucid' 
'--x-includes=/usr/X11R6/include' '--x-libraries=/usr/X11R6/lib' 
'i586-suse-linux' 'CC=gcc' 'CFLAGS=-O2 -march=i586 -mcpu=i686 
-fmessage-length=0 -Wall -pipe      -DSYSTEM_PURESIZE_EXTRA=25000   
-DSITELOAD_PURESIZE_EXTRA=10000         -D_GNU_SOURCE ' 'LDFLAGS=-s' 
'build_alias=i586-suse-linux' 'host_alias=i586-suse-linux' 
'target_alias=i586-suse-linux''
Important settings:
  value of $LC_ALL: nil
  value of $LC_COLLATE: nil
  value of $LC_CTYPE: nil
  value of $LC_MESSAGES: nil
  value of $LC_MONETARY: nil
  value of $LC_NUMERIC: nil
  value of $LC_TIME: nil
  value of $LANG: en_US.UTF-8
  locale-coding-system: utf-8
  default-enable-multibyte-characters: t

Please describe exactly what actions triggered the bug
and the precise symptoms of the bug:

Run emacs the ctwm window manager rather than under kde or gnome.  The block
cursor is never solid and so it is very difficult to tell what buffer is
being edited when you have several windows visible in a frame.  It seems to
have something to do with focus control.  If I tell ctwm to force the focus
to the emacs frame (which means that focus cannot leave that X window until
I use the ctwm menu to move it somewhere else) then the block turns
solid.  But if I just use the normal focus-follows-mouse setting for ctwm
then the block cursor is always hollow.  I think emacs never thinks it
"really" has the focus even though it is getting keyboard and mouse events
and responding to them.  Emacs 20.7 and earlier work correctly with ctwm.
Xterm and the other applications seem to get the focus ok (their cursors
change from hollow to solid).


Recent input:
C-u C-v C-u C-v C-n C-n C-n C-n C-n C-n C-n C-n C-n 
C-n C-n C-n C-n C-n C-s C-s C-s C-a C-b C-u C-u C-v 
C-u C-u C-v C-u C-v C-s C-s C-s C-s C-a C-n C-n C-n 
C-n C-n C-s C-s C-a C-s S e t F o c C-r C-a C-c C-b 
C-s F o c u s C-s C-a C-u C-v C-u C-v C-u C-v C-u C-v 
C-u C-v C-u C-v C-u C-b ` x b u g <tab> <backspace> 
<backspace> <backspace> b ? u ? <backspace> <backspace> 
r e p o r t <tab> <return>

Recent messages:
nil
t
Mark saved where search started [3 times]
call-interactively: Beginning of buffer
Loading cc-mode...done
Mark saved where search started [14 times]
Mark set
Mark saved where search started
Making completion list... [2 times]
Loading emacsbug...done





reply via email to

[Prev in Thread] Current Thread [Next in Thread]