[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Bug for Emacs

From: Pearson, Sean
Subject: Bug for Emacs
Date: Tue, 21 Dec 2004 20:09:56 -0800

I have what I think is a bug to report.

I have emacs-21.2.1 running on Max OSX 10.3.7.  However, before I realized this, I tried to download emacs from ftp.gnu.org, and also ftp.kernel.org.  From kernel .org, I believe I downloaded 21.1 by mistake, and tried to configure it by typing
which failed with the following message:

loading cache ./config.cache
checking host system type... powerpc-apple-darwin7.7.0
configure: error: Emacs hasn't been ported to `powerpc-apple-darwin7.7.0' systems.
Check `etc/MACHINES' for recognized configuration names.

I then downloaded emacs-21.3 from ftp.gnu.org, with a similar result.  Now, on the web at
the operating system Mac-OS X is listed as an OS which Emacs 21 runs on regardless of machine type.  Clearly, I do have emacs running on my machine, so it does work.  Then, there must be a problem with the configure script, or something related to it.  By the way, when I run emacs, on my machine, I get the following in the initial buffer:

Welcome to GNU Emacs

Get help           C-h  (Hold down CTRL and press h)
Undo changes       C-x u       Exit Emacs               C-x C-c
Get a tutorial     C-h t       Use Info to read docs    C-h i
Ordering manuals   C-h RET
Activate menubar   F10  or  ESC `  or   M-`
(`C-' means use the CTRL key.  `M-' means use the Meta (or Alt) key.
If you have no Meta key, you may instead type ESC followed by the character.)

GNU Emacs 21.2.1 (powerpc-apple-darwin7.0)
 of 1976-04-01 on localhost
Copyright (C) 2001 Free Software Foundation, Inc.

GNU Emacs comes with ABSOLUTELY NO WARRANTY; type C-h C-w for full details.
Emacs is Free Software--Free as in Freedom--so you can redistribute copies
of Emacs and modify it; type C-h C-c to see the conditions.
Type C-h C-d for information on getting the latest version.

It appears that my copy of emacs recognizes a different version of the OS or hardware than do the copies I downloaded.

Also, I am unclear on something.  I have been using emacs on my Redhat system, and a port on WinXP.  Both of those support multiple frames.  However, when I typed C-x 5 2 on my copy of emacs, it did nothing, or else it blinked, but I don't see a new top-level window.  If this is because it is running in terminal mode, that I understand.  However, I can't seem to get a copy of emacs running NOT in terminal mode, and I think that if this is impossible, that should be explained somewhere.

Please get back to me about this.

Sean Pearson

reply via email to

[Prev in Thread] Current Thread [Next in Thread]