bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Bug: iso-accents-mode and numerical keboard


From: Hugues Mercier
Subject: Re: Bug: iso-accents-mode and numerical keboard
Date: Wed, 16 Mar 2005 20:24:30 -0800 (PST)

In the file iso-acc.el, the / (slash) is used as a pseudo accent
character, which causes the / key on the numerical keyboard to fail when
iso-accents-mode is enabled. Note that the / key is only used when
iso-languages is set to "latin-1" (default setting).

This can be solved by using | (or any other key not appearing on the
numerical keyboard) instead of / as a pseudo accent character. The
following lines need to be changed in iso-acc.el:

Line 139
(?| (?A . ?\305) (?E . ?\306) (?O . ?\330) (?a . ?\345) (?e . ?\346)

Line 170
(defvar iso-accents-enable '(?' ?` ?^ ?\" ?~ ?|)

There are also a few lines of comments that need to be updated.

I hope it helps,

Hugues Mercier.



Le 15/2/2005, "Hugues Mercier" <address@hidden> a écrit:

>I have found the following bug:
>
>---------------------------------------------------------------------
>
>GNU Emacs 21.3.1 (i386-pc-linux-gnu, X toolkit, Xaw3d scroll bars) of
>2004-10-16 on raven, modified by Debian
>
>---------------------------------------------------------------------
>
>When iso-accents-mode is enabled (M-x iso-accents-mode), the slash
>(division) key on the numerical keyboard stop working. When the key is
>pressed, the following error message is printed:
>
>iso-accents-accent-key: Wrong type argument: integerp, kp-divide
>
>Regards,
>
>Hugues Mercier.




reply via email to

[Prev in Thread] Current Thread [Next in Thread]