bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

The completion of file name does not works properly with utf-8 locale in


From: bloomycat
Subject: The completion of file name does not works properly with utf-8 locale in 'M-x shell'.
Date: Mon, 28 Nov 2005 06:42:03 +0900

This bug report will be sent to the Free Software Foundation,
not to your local site managers!
Please write in English, because the Emacs maintainers do not have
translators to read other languages for them.

Your bug report will be posted to the address@hidden mailing list,
and to the gnu.emacs.bug news group.

In GNU Emacs 21.4.1 (i386-pc-linux-gnu, X toolkit, Xaw3d scroll bars)
 of 2005-03-18 on trouble, modified by Debian
configured using `configure '--build=i386-linux' '--host=i386-linux' 
'--prefix=/usr' '--sharedstatedir=/var/lib' '--libexecdir=/usr/lib' 
'--localstatedir=/var/lib' '--infodir=/usr/share/info' 
'--mandir=/usr/share/man' '--with-pop=yes' '--with-x=yes' 
'--with-x-toolkit=athena' 'CFLAGS=-DDEBIAN -g -O2' 'build_alias=i386-linux' 
'host_alias=i386-linux''
Important settings:
  value of $LC_ALL: nil
  value of $LC_COLLATE: nil
  value of $LC_CTYPE: nil
  value of $LC_MESSAGES: nil
  value of $LC_MONETARY: nil
  value of $LC_NUMERIC: nil
  value of $LC_TIME: nil
  value of $LANG: ko_KR.UTF-8
  locale-coding-system: utf-8
  default-enable-multibyte-characters: t

Please describe exactly what actions triggered the bug
and the precise symptoms of the bug:

I'm using emacs-mule with utf-8 locale on console.  The completion
of file name doesn't work properly in 'm-x shell'.  The completion
of file name which starts ascii works good, but the other completion
of file name which starts non-ascii(like korean or japanese) does
not works.  *Messages* buffer says "No completions of ls =123d1".  My
'.emacs' file is below.

(set-terminal-coding-system 'utf-8)
(set-language-environment 'utf-8)
(set-input-method 'korean-hangul3)
(toggle-input-method)

I'm using emacs and emacs-mule in debian sarge.



Recent input:
C-p C-p C-p C-p C-p C-p C-p C-p C-p C-p C-p C-p C-p 
C-p C-p C-p C-p C-p C-p C-p C-n C-n C-n C-n C-n C-n 
C-n C-n C-n C-n C-n C-n C-n C-n C-n C-n C-n C-n C-n 
C-n C-n C-n C-n C-n C-n C-n C-n C-n C-n C-n C-n C-n 
C-n C-n C-n C-n C-n C-p C-p C-p C-p C-p C-p C-p C-p 
C-a C-@ C-n C-n C-n C-n C-n C-n C-n C-n C-n C-n C-n 
C-n C-n C-n C-n C-n C-p C-p C-p ESC w C-x m C-x k RET 
ESC x ESC p ESC p RET

Recent messages:
"KuYa White"
Auto-saving...
"msmtp"
Wrote /root/.emacs [2 times]
Mark set
Type C-x 4 b RET to restore the other window.  C-M-v to scroll the help.
Wrote /root/emacs-bug-report.txt
mail-send: Quit
Mark set
Saved text from "I'm using emacs-mule with utf-8 locale o"




reply via email to

[Prev in Thread] Current Thread [Next in Thread]