bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Compiling 21.4 for OS X 10.3.9


From: Brian Schack
Subject: Compiling 21.4 for OS X 10.3.9
Date: Tue, 13 Dec 2005 13:36:30 +0800
User-agent: Gnus/5.1007 (Gnus v5.10.7) XEmacs/21.4.17 (Jumbo Shrimp, darwin)

Hi,

I recently tried to compile GNU Emacs 21.4 on OS X 10.3.9.  According
to the documentation at www.gnu.org/software/emacs/emacs.html, OS X is
supported, but when I ran configure, I immediately got this:

% ./configure
creating cache ./config.cache
checking host system type... powerpc-apple-darwin7.9.0
configure: error: Emacs hasn't been ported to `powerpc-apple-darwin7.9.0' 
systems.
% 

However, I *can* compile the so-called Emacs.app (see
emacs-app.sourceforge.net), which is based on GNU Emacs 23.0.0.  Aside
from having files to describe the OS X system in src/s and src/m, I
note that the configure system for Emacs.app seems far more
up-to-date.  For example, the configure command in 21.4 has this in
the header:

# Generated automatically using autoconf version 2.13 
# Copyright (C) 1992, 93, 94, 95, 96 Free Software Foundation, Inc.

But the configure command in Emacs.app looks like this:

# Generated by GNU Autoconf 2.59.
# Copyright (C) 2003 Free Software Foundation, Inc.

This makes me wonder - was an old version of the configure system
accidentally released with 21.4?  Or was this a conscious decision,
and I have to wait for the next major release before I can compile
Emacs for OS X?

Brian

-- 
Brian Schack            mailto: address@hidden
19 Hsu Chang Street 2F  phone:  2381 4727
Taipei 100              fax:    2381 2145
TAIWAN                  






reply via email to

[Prev in Thread] Current Thread [Next in Thread]