bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: emacs-22.1 with GTK dumps core when Gnome wigets clicked


From: Gary Mills
Subject: Re: emacs-22.1 with GTK dumps core when Gnome wigets clicked
Date: Sat, 16 Jun 2007 08:32:52 -0500
User-agent: Mutt/1.5.10i

On Sat, Jun 16, 2007 at 02:22:54PM +0900, YAMAMOTO Mitsuharu wrote:
> >>>>> On Thu, 14 Jun 2007 13:49:25 -0500, Gary Mills <address@hidden> said:
> 
> >> I found a possible problem, which may or may not be relevant to
> >> this issue, in the initialization of the recursive mutex in
> >> src/gmalloc.c.  Could you try this patch?
> 
> > I'm sorry to report that it still dumps core when I click on one of
> > those icons.
> 
> I've set up Solaris 10 11/06 SPARC with Sun Studio 11 and tried
> making/running the GTK+ build, but couldn't reproduce the crash even
> with unmodified Emacs 22.1.  That may be because mine is a
> uniprocessor machine.  What about yours?

That'll be it.  I've run emacs-22.1 on both SPARC and x86 hardware,
but never on a uniprocessor machine.  We don't have any of those left.
However, I just took one CPU offline on my Ultra 60 and tried
emacs-22.1.  When I click on the `Read and existing file' icon, the
`Find File' dialogue window appears just like it should.

When I click on that icon with both CPUs online, I get a very long
pause, after which the emacs window disappears, leaving a 94-meg core
file.

> Could you try yet another patch below and identify the line in the
> source code where the crash occurs?

I'll see what I can do.

-- 
-Gary Mills-    -Unix Support-    -U of M Academic Computing and Networking-




reply via email to

[Prev in Thread] Current Thread [Next in Thread]