bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Can't visit directory using TRAMP


From: Michael Albinus
Subject: Re: Can't visit directory using TRAMP
Date: Sat, 30 Jun 2007 10:34:33 +0200
User-agent: Gnus/5.110006 (No Gnus v0.6) Emacs/22.0.97 (gnu/linux)

Alan Hadsell <address@hidden> writes:

> I attempt to visit a remote directory using TRAMP with the "plink"
> method and dired, and get a (repeatable) error.  The target system is
> GNU/Linux, CentOS 4.4 (equivalent to RHEL4).  The version of PuTTY I'm
> using is 0.60.  This same installation of emacs and PuTTY can
> successfully visit a remote directory on a Red Hat 7.3 system.
> Both systems have:
>
>   alias ls='ls --color=tty'
>
> With debug-on-error set, I receive the following backtrace:
>
> ,----
> | Debugger entered--Lisp error: (error "Format specifier doesn't match 
> argument type")
> |   format(" %-8d" "al")
> |   ls-lisp-format("." (t 9 al users (18053 34063) (16508 26097) (18053 
> 16924) 4096 "drwxr-xr-x" nil 3855200 (-1 0)) 4096 (97 108) nil (18053 37612 
> 574000))
> |   
> ls-lisp-insert-directory("/plink:address@hidden:/home/al/build/scarab-1.0-b19/"
>  (97 108) nil nil t)

You've said in the other message that you are running Tramp 2.1.5. In
the Changelog of Tramp, there is a correction in
tramp-handle-insert-directory wrt to ls-lisp. I don't remember the
details, but it might be worth to upgrade to Tramp 2.1.9, which
contains this fix.

> Alan Hadsell

Best regards, Michael.




reply via email to

[Prev in Thread] Current Thread [Next in Thread]