[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

can't turn off font-lock

From: Karl Berry
Subject: can't turn off font-lock
Date: Sat, 11 Aug 2007 16:24:42 -0500

The Emacs 22.1 manual, Font Lock node, says:

       If you do not wish Font Lock mode to be turned on by default,
    customize the variable `global-font-lock-mode' using the Customize
    interface (*note Easy Customization::), or use the function
    `global-font-lock-mode' in your `.emacs' file, like this:

         (global-font-lock-mode 0)

Ok, so I start Emacs like this:
emacs-22.1 -q --no-site

And invoke:
M-x eval-expression RET (global-font-lock-mode 0) RET

And now I try a few commands:
C-h a font-lock RET             (a *Help* buffer)
M-x grep RET e /etc/issue RET   (grep to get a couple matches)
M-x shell RET pwd RET

In all cases, I observe that fontification is happening.  Argh!
E.g., the "pwd" is highlighted, the grep matches and filenames are
highlighted, the *Help* buffer is fancily formatted.

I also tried (setq font-lock-maximum-size 0).  Also no visible

I also tried with -nw, for Emacs in an xterm.  Same fontified results,
now in the usual xterm-ish ways (underlines and emboldening).

It seems either the manual or the behavior should be fixed.

(Also, if anyone has any details about how I can really turn font-lock
off, that would be great.)


P.S. I also tried customize-group on font-lock-faces, as suggested a
little further in the node, and the interface completely defeated me.  I
could not tell how to turn anything off completely, only how to select
various attributes.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]