bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

offical Emacs 22.1: `term' problem on MS Windows


From: Peter Tury
Subject: offical Emacs 22.1: `term' problem on MS Windows
Date: Mon, 17 Mar 2008 10:49:54 -0700 (PDT)
User-agent: G2/1.0

Hi,

I've just installed official v22.1 from gnu ftp server onto MS Windows
XP. I haven't customized it yet. I tried M-x term and got error:

"Spawning child process: invalid argument"

Then I digged into the code and saw that  term-exec-1 from term.el
uses "/bin/sh" unconditionally. I tried to comment it out, so I got:

"
    (apply 'start-process name buffer
;;         "/bin/sh" "-c"
;;         (format "stty -nl echo rows %d columns %d sane 2>/dev/null;\
;;if [ $1 = .. ]; then shift; fi; exec \"address@hidden""
;;                 term-height term-width)
;;         ".."
           command switches)))
"
and, for first sight it seems to work (since `command' has write
value: "C:/Program Files/emacs-22.1/bin/cmdproxy.exe").

Is this a known bug? Or I misused somethnig?

Thanks in advance,
P


reply via email to

[Prev in Thread] Current Thread [Next in Thread]