bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#152: marked as done (window-line-height returns spurious OFFBOT val


From: Emacs bug Tracking System
Subject: bug#152: marked as done (window-line-height returns spurious OFFBOT values)
Date: Thu, 29 May 2008 11:45:04 -0700

Your message dated Thu, 29 May 2008 14:32:53 -0400
with message-id <address@hidden>
and subject line Re: window-line-height returns spurious OFFBOT values
has caused the Emacs bug report #152,
regarding window-line-height returns spurious OFFBOT values
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact address@hidden
immediately.)


-- 
152: http://emacsbugs.donarmstrong.com/cgi-bin/bugreport.cgi?bug=152
Emacs Bug Tracking System
Contact address@hidden with problems
--- Begin Message --- Subject: window-line-height returns spurious OFFBOT values Date: Sun, 20 Apr 2008 10:45:40 -0400
This appears to be a bug in the new font code.  When Emacs 23 uses a
non-fontconfig font, say:

Emacs.Font: -misc-fixed-medium-r-normal--13-*-*-*-c-70-iso8859-1

then (window-line-height -1) returns a non-zero OFFBOT element, saying
that the last line contains offscreen pixels, when in fact the last line
is completely inside the window.

To reproduce:

  (global-set-key [f1] (lambda () (interactive)
    (message (prin1-to-string (window-line-height -1)))))

Typing f1 in the scratch buffer gives me, e.g.,

  (9 39 510 4)
            ^

Emacs 22, using the exact same font in .Xresources, correctly returns a
zero OFFBOT.

Furthermore, Emacs 23, using a fontconfig font (Monospace-9), also
correctly returns a zero OFFBOT.



--- End Message ---
--- Begin Message --- Subject: Re: window-line-height returns spurious OFFBOT values Date: Thu, 29 May 2008 14:32:53 -0400
> (window-line-height -1) returns a non-zero OFFBOT element, saying that
> the last line contains offscreen pixels, when in fact the last line is
> completely inside the window.

Seems to be fixed now.


--- End Message ---

reply via email to

[Prev in Thread] Current Thread [Next in Thread]