bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#346: marked as done (plot not cleared after plot() commands followi


From: Emacs bug Tracking System
Subject: bug#346: marked as done (plot not cleared after plot() commands following a plotyy())
Date: Mon, 2 Jun 2008 20:45:03 -0700

Your message dated Mon, 02 Jun 2008 23:35:23 -0400
with message-id <address@hidden>
and subject line Re: plot not cleared after plot() commands following a plotyy()
has caused the Emacs bug report #346,
regarding plot not cleared after plot() commands following a plotyy()
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact address@hidden
immediately.)


-- 
346: http://emacsbugs.donarmstrong.com/cgi-bin/bugreport.cgi?bug=346
Emacs Bug Tracking System
Contact address@hidden with problems
--- Begin Message --- Subject: Re: plot not cleared after plot() commands following a plotyy() Date: Sun, 01 Jun 2008 17:42:25 +0200 User-agent: Thunderbird 2.0.0.12 (X11/20080306)
Thomas Weber wrote:
> thanks
> [let's give the tracker a try]
> 
> [ Octave 3.0.1, gnuplot 4.2 patchlevel 2 ]
> 
> The following code leaves fragments of the plotyy() commands in the
> final plot after the plot() command:
> 
> ===================================================================
> x= 1:10;
> y = 1./x;
> z = 10 *x;
> q = 100*x;
> 
> plotyy(x,y,x,z)
> pause
> plotyy(x,y,x,q)
> pause
> plot(x,y)
> ===================================================================


Not sure how to address this in the bug tracker as it should be marked
as "pending" for 3.1.x and "won't fix" for 3.0.x.. In any case its a
known problem. The thread

http://www.nabble.com/RE%3A--Changeset--plotyy-leaves-traces-of-previous-plots-tt16361090.html

discusses it and I even proposed a patch, that partially addresses the
issue, though potentially causes other problems and so John didn't want
to apply it. The solution that is proposed for 3.1.x is to use the
callback code in the octave-graphics branch to create a callback
function that deals with clearing the plotyy plots in the same manner as
 matlab does. However, we need the new graphics handle code in the main
tree, at least before I'd look at the problem. In any case its one of
the issues I have on my todo list.

D.



--- End Message ---
--- Begin Message --- Subject: Re: plot not cleared after plot() commands following a plotyy() Date: Mon, 02 Jun 2008 23:35:23 -0400 User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.0.60 (gnu/linux)
This doesn't seem to be relevant to Emacs,


        Stefan


--- End Message ---

reply via email to

[Prev in Thread] Current Thread [Next in Thread]