bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#648: htmlize.el doesn't work fine


From: Lennart Borgman (gmail)
Subject: bug#648: htmlize.el doesn't work fine
Date: Tue, 05 Aug 2008 11:18:55 +0200
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.9) Gecko/20071031 Thunderbird/2.0.0.9 Mnenhy/0.7.5.666

Juanma Barranquero wrote:
On Tue, Aug 5, 2008 at 08:06, clinif <address@hidden> wrote:

Debugger entered--Lisp error: (error "Invalid face")
  internal-get-lisp-face-attribute(nil :height nil)
  face-attribute(nil :height)

In Emacs 23.X,

  (face-attribute 'default :inherit) => nil

while in Emacs 22.X,

  (face-attribute 'default :inherit) => unspecified

I'm not sure whether that's a bug, but it is an incompatible change.

For the time being, you can patch your htmlize.el, changing one line
of htmlize-face-size, from

          for f = face then (face-attribute f :inherit)

to

          for f = face then (or (face-attribute f :inherit) 'unspecified)


Please also notice that htmlfontify.el was meant to be included in Emacs. Vivek, what has happened with this?







reply via email to

[Prev in Thread] Current Thread [Next in Thread]