[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#677: 23.0.60; emacs23 term on OS X 10.5.4

From: Nurullah Akkaya
Subject: bug#677: 23.0.60; emacs23 term on OS X 10.5.4
Date: Sat, 09 Aug 2008 04:48:21 +0300
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/22.2 (darwin)

i use M-x term with /bin/bash on os x (emacs 22) without any problems after
compiling emacs 23 term started behaving differently when i hit enter i
get the following error

Debugger entered--Lisp error: (wrong-type-argument integerp return)
  make-string(1 return)
  call-interactively(term-send-raw nil nil)

i also get the same error with tab. i tried starting emacs with -q but
still got the same error.

In GNU Emacs (i386-apple-darwin9.4.0, *Step 9.0)
 of 2008-08-07 on blackHole.local
Windowing system distributor `Apple', version 49.46.48
configured using `configure  '--with-ns''

Important settings:
  value of $LC_ALL: nil
  value of $LC_COLLATE: nil
  value of $LC_CTYPE: nil
  value of $LC_MESSAGES: nil
  value of $LC_MONETARY: nil
  value of $LC_NUMERIC: nil
  value of $LC_TIME: nil
  value of $LANG: nil
  value of $XMODIFIERS: nil
  locale-coding-system: utf-8
  default-enable-multibyte-characters: t

Major mode: Lisp Interaction

Minor modes in effect:
  desktop-save-mode: t
  show-paren-mode: t
  flyspell-mode: t
  delete-selection-mode: t
  display-battery-mode: t
  display-time-mode: t
  tooltip-mode: t
  mouse-wheel-mode: t
  file-name-shadow-mode: t
  global-font-lock-mode: t
  font-lock-mode: t
  blink-cursor-mode: t
  global-auto-composition-mode: t
  auto-composition-mode: t
  auto-encryption-mode: t
  auto-compression-mode: t
  column-number-mode: t
  line-number-mode: t
  transient-mark-mode: t
  abbrev-mode: t

Recent input:
n M-x r e p o <tab> r <tab> <return>

Recent messages:
Loading /Users/nurullahakkaya/.emacs.d/my-jump.el (source)...done
Loading /Users/nurullahakkaya/.emacs.d/php-mode.el (source)...done
Loading /Users/nurullahakkaya/.emacs.d/weblogger.el (source)...done
Starting new Ispell process [default] ...
Loading desktop...done
Warning: desktop file appears to be in use by PID 277.
Using it may cause conflicts.  Use it anyway? (y or n) 
Desktop file in use; not loaded.
For information about GNU Emacs and the GNU system, type C-h C-a.
Making completion list...

Nurullah Akkaya

reply via email to

[Prev in Thread] Current Thread [Next in Thread]