[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#680: undefined reference to `syms_of_font'

Subject: bug#680: undefined reference to `syms_of_font'
Date: Sun, 10 Aug 2008 00:17:37 +0900

Do'nt   send  me mail  !!!
no tkank you!!
----- Original Message -----
From: ling hao
Sent: Saturday, August 09, 2008 9:57 PM
Subject: bug#680: undefined reference to `syms_of_font'

Dear all,

I find this problem when I checked out source code and tried to build emacs-unicode-2 in windows with MinGW.

when I use
configure.bat --no-debug --with-gcc --cflags -IC:\gnuw32\include  ( c:\gnuw32\include is where I put image libraries)
it seems ok.

But later, when I run make bootstrap, it always failed with these error.

oo-spd/i386/temacs0.a(emacs.o):emacs.c:(.text+0x1605): undefined reference to `syms_of_font'
oo-spd/i386/temacs1.a(fontset.o):fontset.c:(.text+0x8a1): undefined reference to `Ffont_get'
oo-spd/i386/temacs1.a(fontset.o):fontset.c:(.text+0x1cc2): undefined reference to `QCregistry'
oo-spd/i386/temacs1.a(fontset.o):fontset.c:(.text+0x1cdf): undefined reference to `Ffont_spec'
oo-spd/i386/temacs1.a(fontset.o):fontset.c:(.text+0x2292): undefined reference to `Ffont_spec'
oo-spd/i386/temacs1.a(fontset.o):fontset.c:(.text+0x22b2): undefined reference to `font_parse_xlfd'
oo-spd/i386/temacs1.a(fontset.o):fontset.c:(.text+0x2328): undefined reference to `font_unparse_xlfd'
oo-spd/i386/temacs1.a(fontset.o):fontset.c:(.text+0x2401): undefined reference to `Ffont_spec'
oo-spd/i386/temacs1.a(fontset.o):fontset.c:(.text+0x2415): undefined reference to `font_parse_xlfd'
oo-spd/i386/temacs1.a(fontset.o):fontset.c:(.text+0x247d): undefined reference to `font_unparse_xlfd'
collect2: ld returned 1 exit status
make[2]: *** [oo-spd/i386/temacs.exe] Error 1
make[2]: Leaving directory `E:/emacs-unicode/emacs/src'
make[1]: *** [bootstrap-temacs] Error 2
make[1]: Leaving directory `E:/emacs-unicode/emacs/src'
make: *** [bootstrap-gmake] Error 2

I check the source code and found that the Ffont_get was defined in font.c  but in makefile, font.c is only build when specified --enable-font-backend.

I put font.c in makefile in src folder about in line422. and pass this part.

I don't know if I made any mistake to cause this error, please could you check this issue. Maybe it is a bug.

Newbie to emacs
ling hao

reply via email to

[Prev in Thread] Current Thread [Next in Thread]