bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#540: marked as done (23.0.60; Unicode search bug)


From: Emacs bug Tracking System
Subject: bug#540: marked as done (23.0.60; Unicode search bug)
Date: Wed, 27 Aug 2008 07:40:04 -0700

Your message dated Wed, 27 Aug 2008 10:34:40 -0400
with message-id <address@hidden>
and subject line Re: bug#540: 23.0.60; Unicode search bug
has caused the Emacs bug report #540,
regarding 23.0.60; Unicode search bug
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact address@hidden
immediately.)


-- 
540: http://emacsbugs.donarmstrong.com/cgi-bin/bugreport.cgi?bug=540
Emacs Bug Tracking System
Contact address@hidden with problems
--- Begin Message --- Subject: 23.0.60; Unicode search bug Date: Sun, 06 Jul 2008 21:43:23 +0300 User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.0.60 (x86_64-pc-linux-gnu)
There is a weird bug in searching Unicode text.  The search function
fails on Cyrillic letters between codepoints #x0400 and #x041f, but
successfully finds a Cyrillic letter between #x0420 and #x042f.

I tried to debug this and see that in case of failure
it calls `boyer_moore', and in case of successful search
it calls `simple_search'.  I checked the Unicode properties,
but everything seems correct.

This bug didn't exist before the Unicode merge.

The easiest way to reproduce it: run `emacs -Q',
put in the *scratch* buffer the following 4 lines
(note the leading space):

(search-forward " П" nil t)
(search-forward " Р" nil t)
 П
 Р

and type `C-x C-e' after each of first two lines.

In GNU Emacs 23.0.60 (x86_64-pc-linux-gnu)
Important settings:
  value of $LC_ALL: nil
  value of $LC_COLLATE: nil
  value of $LC_CTYPE: nil
  value of $LC_MESSAGES: nil
  value of $LC_MONETARY: nil
  value of $LC_NUMERIC: nil
  value of $LC_TIME: nil
  value of $LANG: en_US.UTF-8
  value of $XMODIFIERS: nil
  locale-coding-system: utf-8-unix
  default-enable-multibyte-characters: t

-- 
Juri Linkov
http://www.jurta.org/emacs/



--- End Message ---
--- Begin Message --- Subject: Re: bug#540: 23.0.60; Unicode search bug Date: Wed, 27 Aug 2008 10:34:40 -0400 User-agent: Gnus/5.11 (Gnus v5.11) Emacs/22.2.91 (gnu/linux)
Andreas Schwab <address@hidden> writes:

> Should be fixed now.

Thanks!


--- End Message ---

reply via email to

[Prev in Thread] Current Thread [Next in Thread]