bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#613: 23.0.60; Unicode display problems


From: Kenichi Handa
Subject: bug#613: 23.0.60; Unicode display problems
Date: Mon, 01 Sep 2008 11:53:40 +0900
User-agent: SEMI/1.14.3 (Ushinoya) FLIM/1.14.2 (Yagi-Nishiguchi) APEL/10.2 Emacs/23.0.60 (i686-pc-linux-gnu) MULE/6.0 (HANACHIRUSATO)

In article <address@hidden>, address@hidden writes:

> Neep Alt was originally designed for ISO8859-1 encodings,
> and my installation still has iso18859-1 fonts that
> definitely lack LEFT SINGLE QUOTE.  However, I constructed
> additional fonts to support ISO10646-1, by extracting the
> Misc Fixed glyphs outside of ISO8859-1, and appending them
> to the Neep Alt font definitions.  Those fonts are defined
> to have the iso10646-1 encoding.

Ah, I see.

> Adding LEFT SINGLE QUOTE and a couple of others as
> "symbol" representatives let Emacs filter out the
> ISO8859-1 fonts earlier in the code path, leaving the
> ISO10646-1 fonts for Emacs to use.  The Misc Fixed fonts
> had the same problem, as they also included ISO8859-1 and
> ISO10646-1 encodings, and this solution worked for them as
> well.

I re-added `symbol' entry to script-representative-chars but
with vector of characters as this:

        (symbol . [#x201C #x2200 #x2500])

and modified ftfont.c to handle that kind of format to
fileter out fonts that have none of characters in the
vector.

Please you try again with the latest code.

---
Kenichi Handa
address@hidden






reply via email to

[Prev in Thread] Current Thread [Next in Thread]