bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#547: 23.0.60; Euro symbol not displayed


From: Óscar Fuentes
Subject: bug#547: 23.0.60; Euro symbol not displayed
Date: Tue, 09 Dec 2008 20:08:18 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.0.60 (windows-nt)

"Juanma Barranquero" <address@hidden> writes:

[snip]

> Editing it with emacs -q euro.txt shows the euro sign normally:
>
>         character: € (8364, #o20254, #x20ac)
> preferred charset: windows-1252 (WINDOWS-1252 (Latin I))
>        code point: 0x80
>            syntax: _  which means: symbol
>          category: c:Chinese h:Korean j:Japanese
>       buffer code: #xE2 #x82 #xAC
>         file code: #x80 (encoded by coding system windows-1252-dos)
>           display: by this font (glyph code)
>     uniscribe:-outline-DejaVu Sans
> Mono-normal-normal-normal-mono-13-*-*-*-c-*-iso10646-1 (#x70A)

I open a file that contains the euro symbol, scroll down until it is
shown, emacs starts sucking 100% cpu for 15 seconds or so on the 550MHz
CPU I'm using, and finally it displays a box.

My default font is

-outline-Courier New-normal-normal-normal-mono-13-*-*-*-c-*-iso8859-1

Then I eval

(set-default-font "-outline-DejaVu Sans 
Mono-normal-normal-normal-mono-13-*-*-*-c-*-iso10646-1")

and the euro symbol is displayed correctly.

So the default font plays a key role here.

-- 
Oscar






reply via email to

[Prev in Thread] Current Thread [Next in Thread]