bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#1096: marked as done (The Emacs 23 cann't display the cjk extb char


From: Emacs bug Tracking System
Subject: bug#1096: marked as done (The Emacs 23 cann't display the cjk extb characters again.)
Date: Thu, 11 Dec 2008 05:20:03 -0800

Your message dated Thu, 11 Dec 2008 21:14:00 +0800
with message-id <address@hidden>
and subject line Re: bug#1096: The Emacs 23 cann't display the cjk extb 
characters again.
has caused the Emacs bug report #1096,
regarding The Emacs 23 cann't display the cjk extb characters again.
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact address@hidden
immediately.)


-- 
1096: http://emacsbugs.donarmstrong.com/cgi-bin/bugreport.cgi?bug=1096
Emacs Bug Tracking System
Contact address@hidden with problems
--- Begin Message --- Subject: The Emacs 23 cann't display the cjk extb characters again. Date: Mon, 6 Oct 2008 10:25:47 +0800
Dear all,

Now, I updated the Emacs 23 to 23.0.60.1 (i386-mingw-nt5.1.2600) of 2008-10-03 
on LENNART-69DE564, then I find that I cann't see the correct cjk extb 
characters displayed by this version.  For example, the Chinese character 
uni20021, a character of cjk extb, which can be displayed correctly by using 
the previous versions by LENNART, cann't be displayed correctly now.  In 
addition, I can display that character on my box with emeditor, denoting that 
I've the corresponding fonts installed correctly.  Finally, I've use the 
following settings in my _emacas file which is suggested by Kenichi Handa:

--------------
(if (display-graphic-p)
(set-fontset-font
 (frame-parameter nil 'font)
 '(#x20000 . #x2fa1d)
 '("*-Sun-ExtB" . "unicode-sip")))
--------------

Please find the snapshot of this issue in the attachments. 

Regards,
-- 
Hongyi Zhao <address@hidden> 
Xinjiang Technical Institute of Physics and Chemistry
Chinese Academy of Sciences 
GnuPG DSA: 0xD108493
2008-10-5

Attachment: uni20021.txt
Description: Text document

Attachment: display_by_emeditor.png
Description: PNG image

Attachment: display_by_emacs.png
Description: PNG image


--- End Message ---
--- Begin Message --- Subject: Re: bug#1096: The Emacs 23 cann't display the cjk extb characters again. Date: Thu, 11 Dec 2008 21:14:00 +0800 User-agent: Thunderbird 2.0.0.18 (Windows/20081105)
Kenichi Handa wrote:
I've just installed a fix.  At least with Xft font backend,
Emacs should be able to find a proper font for the Unicode
SIP area (#x20000..#x2FFFF) now.

In addition to that change, which should help with displaying those characters by default, it turns out there is a bug in the Windows function that we use to encode characters into glyph points when passed a surrogate pair. I've worked around it by using an oversized glyph buffer.




--- End Message ---

reply via email to

[Prev in Thread] Current Thread [Next in Thread]