bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#1534: marked as done (Font lock decoration levels mismatch?)


From: Emacs bug Tracking System
Subject: bug#1534: marked as done (Font lock decoration levels mismatch?)
Date: Fri, 12 Dec 2008 20:25:05 -0800

Your message dated Fri, 12 Dec 2008 23:21:35 -0500
with message-id <address@hidden>
and subject line Re: bug#1534: Font lock decoration levels mismatch?
has caused the Emacs bug report #1534,
regarding Font lock decoration levels mismatch?
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact address@hidden
immediately.)


-- 
1534: http://emacsbugs.donarmstrong.com/cgi-bin/bugreport.cgi?bug=1534
Emacs Bug Tracking System
Contact address@hidden with problems
--- Begin Message --- Subject: Font lock decoration levels mismatch? Date: Wed, 10 Dec 2008 11:51:33 -0800
I'm using:
GNU Emacs 23.0.60.1 (i486-pc-linux-gnu, GTK+ Version 2.14.3) of
2008-10-13 on rothera, modified by Debian

The documentation at "23.6.1 Font Lock Basics" and "23.6.5 Levels of
Font Lock" refers to level numbers starting at 1, but when I customize
the level for a specific mode (one I'm still developing) the number
given to Customize is 0-based not 1-based; i.e., my `font-lock-defaults'
`KEYWORDS' member is like `(level-1 level-2 level-3 level-4)' and, e.g.,
to make Customize use level-3 I have to tell it the number 2.  Should
Customize do 1-based indexing instead so it corresponds to the
documentation, or the documentation use 0-based?

-- 
: Derick
----------------------------------------------------------------





--- End Message ---
--- Begin Message --- Subject: Re: bug#1534: Font lock decoration levels mismatch? Date: Fri, 12 Dec 2008 23:21:35 -0500 User-agent: Gnus (www.gnus.org), GNU Emacs (www.gnu.org/software/emacs/)
I have clarified the documentation.


Glenn Morris wrote:

> There should be a separate element at the start giving the default
> highlighting for the mode.

BTW, it's not really the "default" any more. It's the level used when
font-lock-maximum-decoration has a nil value. Nowaways it is t by
default.


--- End Message ---

reply via email to

[Prev in Thread] Current Thread [Next in Thread]