bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#1591: Failed to compile emacs from CVS with the new glibc-2.9-3.i686


From: Håvard Rue
Subject: bug#1591: Failed to compile emacs from CVS with the new glibc-2.9-3.i686
Date: Tue, 16 Dec 2008 09:50:18 +0100

My build of emacs23 wouldn't start (segfault)  the other day, and I
tried to compile it again from the source. It fail to compile 

`/bin/pwd`/temacs --batch --load loadup bootstrap
make[3]: *** [bootstrap-emacs] Segmentation fault (core dumped)

And if I run it in the debugger, I get

localhost[src]$ gdb ./temacs
GNU gdb Fedora (6.8-29.fc10)
Copyright (C) 2008 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later
<http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show
copying"
and "show warranty" for details.
This GDB was configured as "i386-redhat-linux-gnu"...
SIGINT is used by the debugger.
Are you sure you want to change it? (y or n) [answered Y; input not from
terminal]
DISPLAY = :0.0
TERM = xterm
Breakpoint 1 at 0x813ced9: file sysdep.c, line 1135.
(gdb) run --batch --load loadup bootstrap
Starting program: /home/hrue/sw/emacs/src/temacs --batch --load loadup
bootstrap
[Thread debugging using libthread_db enabled]
[New Thread 0x40108280 (LWP 7072)]

Program received signal SIGSEGV, Segmentation fault.
0x005081eb in _dl_init_internal () from /lib/ld-linux.so.2

Missing separate debuginfos, use: debuginfo-install
alsa-lib-1.0.18-6.rc3.fc10.i386 atk-1.24.0-1.fc10.i386
bzip2-libs-1.0.5-3.fc10.i386 cairo-1.8.0-1.fc10.i386
dbus-libs-1.2.8-1.fc10.i386 e2fsprogs-libs-1.41.3-2.fc10.i386
expat-2.0.1-5.i386 fontconfig-2.6.0-3.fc10.i386
freetype-freeworld-2.3.7-2.fc10.i386 giflib-4.1.3-9.i386
glib2-2.18.3-2.fc10.i386 glibc-2.9-3.i686 gtk2-2.14.4-3.fc10.i386
libICE-1.0.4-4.fc10.i386 libSM-1.1.0-2.fc10.i386
libX11-1.1.4-6.fc10.i386 libXau-1.0.4-1.fc10.i386
libXcomposite-0.4.0-5.fc10.i386 libXcursor-1.1.9-3.fc10.i386
libXdamage-1.1.1-4.fc9.i386 libXdmcp-1.0.2-6.fc10.i386
libXext-1.0.4-1.fc9.i386 libXfixes-4.0.3-4.fc10.i386
libXft-2.1.13-1.fc10.i386 libXi-1.1.3-4.fc9.i386
libXinerama-1.0.3-2.fc10.i386 libXpm-3.5.7-4.fc9.i386
libXrandr-1.2.3-1.fc10.i386 libXrender-0.9.4-3.fc9.i386
libcap-2.10-2.fc10.i386 libcroco-0.6.1-5.fc9.i386
libgsf-1.14.10-1.fc10.i386 libjpeg-6b-43.fc10.i386
libpng-1.2.33-1.fc10.i386 librsvg2-2.22.3-1.fc10.i386
libselinux-2.0.73-1.fc10.i386 libtiff-3.8.2-11.fc10.i386
libxcb-1.1.91-5.fc10.i386 libxml2-2.7.2-2.fc10.i386
ncurses-libs-5.6-20.20080927.fc10.i386 pango-1.22.3-1.fc10.i386
pixman-0.12.0-2.fc10.i386 zlib-1.2.3-18.fc9.i386


seems like a new glibc has just recently been installed

localhost[~]$ rpm -qf /lib/ld-2.9.so 
glibc-2.9-3.i686


I'm running Fedora 10. 

Bests,
Håvard



-- 
 Håvard Rue
 Department of Mathematical Sciences
 Norwegian University of Science and Technology
 N-7491 Trondheim, Norway
 Voice: +47-7359-3533    URL  : http://www.math.ntnu.no/~hrue  
 Fax  : +47-7359-3524    Email: address@hidden

 Please avoid sending me Word or PowerPoint attachments,
 see http://www.gnu.org/philosophy/no-word-attachments.html
 This message was created in a Microsoft-free computing environment.









reply via email to

[Prev in Thread] Current Thread [Next in Thread]